Welcome to WebmasterWorld Guest from

Forum Moderators: bill

Message Too Old, No Replies

Problem installing Win XP Pro on SATA disk

Install becomes a contnuous loop

2:29 pm on Oct 1, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Oct 21, 2002
votes: 0

I have a Win XP Home system on an 80GB IDE disk which I am tring to convert to Win XP Pro on two Samsung SpinPoint 250GB SATA disks (not in RAID).

I have partitioned and formatted the new disks from the old system using Partition Magic. Then removed the old IDE disk and tried to install Win XP Pro. Setup asks for the SATA dirver, and then installs the files on the new disk correctly. But when it reboots Setup starts all over again, loading files into memory, asking for the driver again, and then tells me I already have an operating system on the disk. If I continue it just goes into a loop, reinstalling the files and then rebooting.

I have tried everything I can think of in the Bios. I have tried taking the install CD out when it goes to reboot. But nothing gets it to work.

I haven't found anything on the usual forums which has helped. I've spent the best part of two days working on this! So if anybody can help will be eternally grateful.:)


Abit VI7 V10 motherboard, Pentium P4 2.4, and 2 Samsung Spinpoint 250 GB Sata disks formatted FAT32. The first Spinpoint has a 40GB primary Active partition which is where I am trying to install Windows.

3:43 pm on Oct 1, 2005 (gmt 0)

Senior Member from CA 

WebmasterWorld Senior Member 10+ Year Member Top Contributors Of The Month

joined:Nov 25, 2003
votes: 275

If the HD has jumpers try removing the jumper.

Also while SATA HDs should not require drivers SATA host adapters often do - they should be on the floppy/CD that can with your SATA card or motherboard. There is a very short time-point when Windows asks you to hit F6 (look bottom of screen) during text-mode set-up.

5:23 pm on Oct 1, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Oct 21, 2002
votes: 0

No the HD does not have jumpers fitted. They only need to be fitted on mine if Sata150 is not correctly identified, but my disks are working OK.

The drivers are OK. Windows asks for them and I have them on a floppy. A symptom of the problem is that after writing files to disk, when it reboots it asks for them again - which it shouldn't need to.

Since my first post I have flashed the bios to the latest version. Made no difference at all. :(

I have tried loading other OS.

My copy of Win XP Home is an upgrade so won't install unless Win98 or 2000 is installed first. :(

My copy of Win 2000 won't run Setup under DOS, so I ran it from a lower level file - but then it doesn't ask for the driver so it can't find the disks. :(

My copy of Win 98 won't work because only 98SE or ME supports Sata. :(

And I have tried running Win XP Pro from XP Home, but it refuses, probably because it's OEM. :(

I can't see any solution for this. Help!

5:37 pm on Oct 1, 2005 (gmt 0)

Junior Member

10+ Year Member

joined:Dec 13, 2004
votes: 0

Just a quick point on Win XP Home Upgrade, the version I have (about 2 years old) allows you to just put the old Win 98 cd in. You don't need to have it loaded on the hard disk.

Hope MS haven't changed this.

9:19 pm on Oct 1, 2005 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:Oct 21, 2002
votes: 0

Thanks all,

I have solved the problem (sort of). The options in the Bios are not the same as the manual which is confusing. So it was trial and error.

I removed all disks except Sata1, enabled the RAID ROM in Bios, and Windows installed OK. Put the second disc on and that was OK. But it only works as long as the SATA/RAID drivers that came with the Mobo are not loaded after the installation. If they are, it switches into RAID mode and the system fails. With Microsoft's drivers it functions as standard Sata.

One other frustration. When I installed XP Pro I set the system date and time. Now XP Home won't let me in on the other disk because the registration has expired.

Don't you just love upgrades?