Welcome to WebmasterWorld Guest from 54.145.209.34

Forum Moderators: goodroi

XML sitemaps encoded characters and GWT

GWT reports 1 URL indexed from all sitemaps

   
4:11 pm on May 22, 2013 (gmt 0)

10+ Year Member



Following Google's own advice on XML sitemaps, I have encoded ampersands with & a m p ; (spaces so WebmasterWorld doesn't decode it)

Now, in Google Webmaster tools, all of my sitemaps have 1 URL indexed out of thousands, presumably the homepage.

Is there a disconnect in GWT where they don't reconcile that this URL:
example.com/some?stuff&more_stuff
is the same as
example.com/some?stuff& a m p ;more_stuff
1:51 pm on May 23, 2013 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



Just a thought - the value of your <loc> elements aren't being enclosed in CDATA (unparsed character data) delimiters by your sitemap generator / script are they? If that was the case, & should not be entity encoded as &amp; since XML entities don't apply within CDATA. For example, without CDATA delimiters:

<url>
<loc>http://www.example.com/page.php?foo=1&amp;bar=2</loc>
</url>

<loc> will be parsed as http://www.example.com/page.php?foo=1&bar=2

Whereas with CDATA delimiters:

<url>
<loc><![CDATA[http://www.example.com/page.php?foo=1&amp;bar=2]]></loc>
</url>

<loc> will be "parsed" literally as http://www.example.com/page.php?foo=1&amp;bar=2
9:13 pm on May 29, 2013 (gmt 0)

10+ Year Member



Thanks for the reply dmorison - nope, no CDATA in the sitemaps... they've been submitted for months now. All a bit strange.
 

Featured Threads

Hot Threads This Week

Hot Threads This Month