Welcome to WebmasterWorld Guest from 54.166.54.215

Forum Moderators: werty

AdCenter is soooooo SLOW!

   
5:31 pm on Oct 7, 2010 (gmt 0)

5+ Year Member



I can't stand it. Right now I can't even login. It just says loading, loading, loading and eventually a dialogue box pops up and says "The action you have requested has failed."

This happens a lot when I'm working in adcenter. I'll click on an ad group or something and nothing happens, it just loads, and then the same message appears. It's pretty aggravating when you have 100's of ad groups.

First they double the number of ad groups I have in order to reach Bing.ca, and now the system is at least 3 times slower than Yahoo's, so basically my job takes a LOT longer than it used to.

/rant
3:35 pm on Oct 8, 2010 (gmt 0)

WebmasterWorld Senior Member tropical_island is a WebmasterWorld Top Contributor of All Time 10+ Year Member



I just went into my AdCenter account for the first time in months.

What can I say?

Volume is so low in comparison to AdWords that it's a joke.
I revised all my keywords to adjust bids but mostly they indicate that I show up 1 or 2 without any changes.

With the same keywords I spend up to $1000 per month with AdWords. My bill last month from from MS was $13.00.

Not worth the time or trouble unless some major changes occur.
8:08 pm on Oct 9, 2010 (gmt 0)

WebmasterWorld Senior Member 5+ Year Member



once they flip the yahoo switch (soon!), and assuming you don't dig down to the ad group level and change distribution settings, there'll be volume alright.
 

Featured Threads

My Threads

Hot Threads This Week

Hot Threads This Month