Welcome to WebmasterWorld Guest from 50.16.47.14

Forum Moderators: werty

Message Too Old, No Replies

Price Level Qualification on Search Terms

...that have no sponsored results.

   
2:56 pm on Nov 21, 2009 (gmt 0)

10+ Year Member



I've never dealt with adcenter and I don't do alot of PPC. I setup an adcenter campaign a few days ago to target some specfic keywords. There are no sponsorsed results for this set of keywords. Since there were no bidders I set my bid at $0.20 thinking it should show up. Two days later my ads still aren't showing up. Does adcenter or any ppc engine require certain price levels to be met even on terms that are unsponsored? If so why. Would they not rather fill their inventory with a paying customer rather than let search terms go unsponsored?

Confused on this. Thanks for any clarification.

8:03 am on Nov 23, 2009 (gmt 0)



If this is your first ppc campaign, there is a good chance that you set it up in a way that simply never shows. For example "blue widgets" with a negative keyword of "widgets". Have a good look at the syntax, paying attention to whether you use parenthesis or square brackets.

Is the keyword a Trademark or an obscene term?

2:40 pm on Nov 23, 2009 (gmt 0)

WebmasterWorld Senior Member 5+ Year Member



I am also new at adcentre. Set up a campaign and it took 4 days for the ad to be approved. So first check if the same has been approved.

Now that, it has been approved.. I am waiting for the ad impressions.. Still working on that..so can't advise. ( I am at zero impressions currently..I suppose I got to give it a day or two..)

2:41 pm on Nov 23, 2009 (gmt 0)

10+ Year Member



This is my first campaign with bing, but not others. Keywords are setup properly, no negative keywords, no brackets or parenthesis. Just plain old text keywords. No trademarks or obscenity.
2:57 pm on Nov 23, 2009 (gmt 0)

10+ Year Member



I figured mine out. Here's how it was. Every single status message on my account said 'Active' in green. In checking back over all pages I went back to my accounts page. I noticed the message under financial status said 'on hold'. I updated the information again and ads began showing.

The tricky part here was that there was no account on hold status notification on dashboard or campaign pages. On top of that all the other status messages said active. A little confusing...

4:16 pm on Nov 23, 2009 (gmt 0)

WebmasterWorld Senior Member 5+ Year Member



thanks .. rushing to the adcenter login..
11:48 am on Nov 24, 2009 (gmt 0)



So basically, the credit card was out of date or some other element stopped the card?
2:18 pm on Nov 24, 2009 (gmt 0)

WebmasterWorld Senior Member 5+ Year Member



I am really confused. Y/day , I saw a few hundred impressions and a few clicks. But today when I try to see the keyword performace all I can see is 1 ( yes one ) impression. What is happenning .. Is it a bug , I am not aware of..?