Welcome to WebmasterWorld Guest from 54.160.163.163

Forum Moderators: werty

Message Too Old, No Replies

Frustration!

     

flanker23

10:42 pm on Nov 6, 2009 (gmt 0)

5+ Year Member



I am a UK based Adcenter user and I have one campaign with some ad groups targetting the US and some ad groups targetting the UK. All my UK targetted ad groups receive plenty of impressions (and clicks) often thousands per day but every ad group I've created aimed at the US I'm lucky to get a hundred impressions a day! I don't believe it's just a bid price issue because the impressions I do get are in typically number 1 or number 2 positions? I took this issue up with Adcenter recently over just one US targetted ad group and they could't provide an answer or a reason beyond 'bid price'? Anybody else experienced this? Btw the research tool indicates the keywords I'm using should receive thousands of impressions a day (if it's anywhere near accurate).

Tropical Island

7:11 pm on Nov 8, 2009 (gmt 0)

WebmasterWorld Senior Member tropical_island is a WebmasterWorld Top Contributor of All Time 10+ Year Member



I have exactly the same problem.

I wrote them this past week asking why I wasn't getting any or very few impressions on my US program.

This is the approximate answer paraphrased.

"We see that your program was opened in 2006.
We see that you are receiving some impressions but not nearly as many as you could be. Sometimes when a campaign or ad group is not getting very much activity for a long period of time the ad will start showing less and less because it is not performing. That may be what has happened with your campaign.

My suggestion is to start two brand new campaigns and copy all of the data over from your existing campaigns."

At that point I stopped reading.
What a farce!

edit: I might add that we have a very high CTR & position for the few impressions we are getting

flanker23

7:18 pm on Nov 8, 2009 (gmt 0)

5+ Year Member



If they don't know why it's really happening and what to do about it we've got no chance!

Brian adCenter

5:09 pm on Nov 9, 2009 (gmt 0)

5+ Year Member



Hi All,

This sounds like it is an issue with your Distribution Channel. By the sounds of it, you had created a campaign with both US and UK targeting and you are not getting any results with the US targeted Ad Groups. To resolve this, you can create a account (Accounts & Billing Tab) and select the EN-US Distribution channel. This will allow any campaigns you create to deliver in the US.

Thank you,

Brian H - MSFT

flanker23

8:17 pm on Nov 9, 2009 (gmt 0)

5+ Year Member



Ok, thanks for the reply Brian, I will try that. If it works, the UK call center needs to be told about that one!

flanker23

7:04 am on Nov 10, 2009 (gmt 0)

5+ Year Member



Well, that did not work Brian. I set up a new account under accounts & billing, set english as my language and then set up one ad group that should receive over 90,000 impressions a month and I've got 40 impressions in the last 12-24 hours!
When you set up an ad group you can select the distribution channel so why shouldn't it work? Actually, there's just one or two ad groups targeting the US in my established campaign that are receiving impressions normally?

flanker23

4:16 pm on Nov 11, 2009 (gmt 0)

5+ Year Member



Tropical Island, looks like we're resigned to not getting much US traffic which seems a serious handicap with Adcenter to me, and a serious loss of revenue for us and Adcenter if they can't pinpoint the problem.

Tropical Island

11:24 am on Nov 12, 2009 (gmt 0)

WebmasterWorld Senior Member tropical_island is a WebmasterWorld Top Contributor of All Time 10+ Year Member



They just sent me another email asking why I didn't reply to the first one.

My total spend for the last few months is around US$20 per month with them.

My spend with AdWords for the same keywords is around US$800 per month.

I just don't have the time or energy to try & correct their internal glitches.

 

Featured Threads

Hot Threads This Week

Hot Threads This Month