Welcome to WebmasterWorld Guest from

Forum Moderators: werty

Message Too Old, No Replies

No Impressions. Ads stopped being displayed!



6:50 am on Jan 20, 2008 (gmt 0)

5+ Year Member

I have been running some campaings for 2 months. When I started optimizing bids my ads stopped being shown on msn and live. I have no impressions at all.

Rep says my site is not banned, but I need to change ads and increase bids which are not copetetive.

My bids ARE competetive, I change my ads I still have no impressions or just a few while before I had thousands and CTR apx 2%.

Did msn rep lie and why?
Can it be the problem with my landing pages?

Thanks for any help.


5:11 pm on Jan 22, 2008 (gmt 0)

WebmasterWorld Senior Member netmeg is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

They did the same to some of my accounts. I just pulled all my own and my clients' accounts out of adCenter and shifted the budgets back to Google - nine accounts in all - I don't have time for this, and the returns haven't been worth it.

Osagie Irowa

8:21 pm on Jan 23, 2008 (gmt 0)

5+ Year Member

Stick with Google for your online advertising. It's not worth the hassle and MSN sucks anyway for search. regards, osagie irowa

[edited by: jatar_k at 4:22 am (utc) on Jan. 24, 2008]


7:17 am on Jan 24, 2008 (gmt 0)

5+ Year Member

I've been getting way more traffic from my UK targetted ad groups than those targetted at the US for weeks now? How can that be?


10:02 pm on Jan 28, 2008 (gmt 0)

10+ Year Member

Your life will suddenly improve when you forget about MSN - I had a great 2007!


3:45 am on Jan 29, 2008 (gmt 0)

5+ Year Member

The thing is that the account was doing prety well. 2000 usd spendings per day, but one day it was blocked it seems - no impressions.

I have an account on google but I need the traffic from MSN as well and to open new account is a nightmare. I have been trying to open the new account since more than 1 month and nothing up to this time - problems with everything! It is like in the Kafka' s the Trial


8:46 pm on Mar 5, 2008 (gmt 0)

5+ Year Member

Something is very wrong with adcenter. Yesterday all my campaigns (maybe 40 separate ad groups) stopped getting impressions. Just like that. Meanwhile everything still said Active; but nothing actually was.

I figured they banned my account for some reason or there was a technical problem so I called a rep; they just told me it maybe a quality score thing; so I just need to get rid of low ctr keywords and submit slightly changed ads. I did so and still no impressions! Even though supposedly the ads are 'active''

I think ok, let try creating another account (same user) this morning and try a couple of adgroups. I get impressions for about 30 minutes and then it all stops! Even with a ctr of over 1% ! Yet everything is still marked 'Active'.

Seriously, #*$! is going on here? I guess MSN decided they didn't want my 4 figures a month in business, but they don't even have the decency to admit they have stopped my entire account for some reason? Nice.


2:23 am on Mar 6, 2008 (gmt 0)

5+ Year Member

^^^^^^^^^^^^Exact same thing. I like the traffic but it pales in comparison, volume-wise, to even YSM.

The rep said the same thing, modify ads so they are looked at again and add all three keyword types - I just have broad. I don't have time for it right now.

I hope they don't buy Yahoo, lol.


8:21 pm on Mar 6, 2008 (gmt 0)

5+ Year Member

New campaigns seem to be running finally. LOL and here I thought Adcenter was out of beta.

Featured Threads

Hot Threads This Week

Hot Threads This Month