Welcome to WebmasterWorld Guest from 54.196.238.210

Forum Moderators: anallawalla & bakedjake

Message Too Old, No Replies

No Statistics in Google Maps

     

AnkitMaheshwari

4:13 am on Jun 30, 2009 (gmt 0)

5+ Year Member



My Google Maps account do not show any statistics since the announcement of the new analytic data reports for the Google LBC.

How can I view the data and has anyone else also experiencing the same problem?

dertyfern

6:03 am on Jul 1, 2009 (gmt 0)

10+ Year Member



Yup, I have the same problem. Don't know why.

Silvery

3:14 pm on Jul 1, 2009 (gmt 0)

5+ Year Member



I have seen the Local Business Center reports lag behind by two days or so at times. When this happens, the graphs show zero traffic for those two days, and then in another day or so when their traffic number-crunching catches up, the graphs suddenly bounce up to showing normal traffic patterns.

Also, if you've been penalized in Google Maps, your listing might abruptly drop down to zero traffic levels. You should do some typical searches where your listing was appearing, and see if it's still showing up in the search results.

If you think you have been penalized, you should revise your LBC business profile to match up with their quality guidelines. Google LBC recently revised their quality guidelines, becoming slightly more conservative in what is and is not allowed.

dertyfern

6:07 pm on Jul 1, 2009 (gmt 0)

10+ Year Member



My listing has been up for a few months and I've been waiting for stats to display ever since the announcement that they were available...but nothing showing yet, though my listing is still displaying prominently so no penalties here.

AnkitMaheshwari

4:37 am on Jul 3, 2009 (gmt 0)

5+ Year Member



My listing are up and running on same positions from past 5 months however, no data since the change in display.

In all 5 of our local offices are verified in the account with phone verification and they all show up.

AnkitMaheshwari

5:13 am on Aug 27, 2009 (gmt 0)

5+ Year Member



Hi,

Any update on the statistics issue as I am still not able to see any in my interface.

Anything I can do to get this sorted?

 

Featured Threads

Hot Threads This Week

Hot Threads This Month