Welcome to WebmasterWorld Guest from

Forum Moderators: bakedjake

Message Too Old, No Replies

VSFTP is not starting

FTP,CENTOS,plesk,ssh,install, vsftp



4:12 am on Feb 4, 2011 (gmt 0)

5+ Year Member

Hi everyone, I have my own dedicated server and for some very weird reason(s) it just stopped working, so I ran yum remove vsftp and I also re installed it again using yum, but now when I run service vsftpd stop it comes bas as FAILED and when I run the service vsftpd start it still fails.

so I decided to take a peek into the config file so I typed:
vi /usr/sbin/vsftpd /etc/vsftpd/vsftpd.conf

and here is what I get:

^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@´ã^A^@^@^@^@^@´ã^A^@^@^@^@^@^@^@ ^@^@^@^@^@^A^@^@^@^F^@^@^@¸ã^A^@^@^@^@^@¸ã!
^@^@^@^@^@¸ã!^@^@^@^@^@Ø^S^@^@^@^@^@^@h%^@^@^@^@^@^@^@^@ ^@^@^@^@^@^B^@^@^@^F^@^@^@èã^A^@^@^@^@^@èã!
^@^@ ^@^@^@^@^@^@^@ ^@^@^@^@^@^@^@^D^@^@^@^@^@^@^@Påtd^D^@^@^@¸¥^A^@^@^@^@^@¸¥^A^@^@^@^@^@¸¥^A^@^@^@^@^@¬^M^@^@^@^@^@^@¬^M^@^@^@^
@^@ ^@^@^@^@^@^@^@a^@^@^@§^@^@^@^P^@^@^@
^@^@^@aX<8c>^F^@<85>`^X"ª^B@<81><90> A^B^T^D<80>^@^BAA^D"ð3@Iª^B<84>B^@^@ 0^D
(^PK$a<8a>^RD^@<82>$^@è^D<80>^A"P^@^U^@^F<88>@¦À <82>^@<90>@^A<80>
@ @ @ @ @ @ @

I tried to remove and install it again and I still get this config How can I fix this issue? any help is appreciated.

[edited by: engine at 9:17 am (utc) on Feb 4, 2011]
[edit reason] formatting [/edit]


8:32 am on Feb 4, 2011 (gmt 0)

WebmasterWorld Senior Member lammert is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

You accidentally also loaded the executable in the editor. Instead of

vi /usr/sbin/vsftpd /etc/vsftpd/vsftpd.conf

you should type

vi /etc/vsftpd/vsftpd.conf

Featured Threads

Hot Threads This Week

Hot Threads This Month