Welcome to WebmasterWorld Guest from 54.146.180.94

Forum Moderators: buckworks & eWhisper & skibum

adword not running

i,ve run ad on adword but it is not running

   
12:54 pm on Nov 2, 2010 (gmt 0)



i run ad on adword but it is not responding. even page impressions are above 100. i need valuable suggestion.
thank you.
10:04 pm on Nov 4, 2010 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



You say it's not running but you have over 100 impressions so it sounds like it is running. You need to give us more information to be able to help you.
8:02 pm on Nov 5, 2010 (gmt 0)



I have the very same problem. Everything set up with keywords accepted.

When I had 153 impressions without any click through I searched some of my best keywords on Google Search but no ad was showing up.

Strange as this new ad campagne of mine has exactly the same setup as my former which was performing really well.
-
6:42 pm on Nov 8, 2010 (gmt 0)

5+ Year Member



What are the keywords?
Are they relevant to the url you are pointing them to?
Are you going through your budget quickly?
7:38 pm on Nov 8, 2010 (gmt 0)



I have keyword like "undirburdur". This keyword is accepted and budget is OK. Also the Url is "undirburdur.is" + text is containing the word.
One would think when entering the keyword to google search the ad would appear on the right panel. But it does not.
Gaining a lot of impressions but zero clicks and zero click throughs.
 

Featured Threads

Hot Threads This Week

Hot Threads This Month