Welcome to WebmasterWorld Guest from 54.146.194.42

Forum Moderators: buckworks & eWhisper & skibum

Message Too Old, No Replies

Adword Assist Please.

managed placement ads not showing

     
5:08 pm on Dec 29, 2009 (gmt 0)

Junior Member

5+ Year Member

joined:Aug 19, 2006
posts:61
votes: 0


I create a campaign with two adgroups

Campaign settings:
Enabled
Budget: $#*$!#*$!xx00.00/day
Targeting: Managed content placements
All devices
English
United States

the ads groups contain the same content placements (ie both target the same site)

Both ads are "approved"

one adgroup displays, and the impressions can be controlled with changes in CPM.

the other adgroup doeshave a single impression, even after many days, with three times the CPM of the other.

I've checked every adgroup, ad, and placement setting. I can;t see any difference between the two except the actual ad (and I've tried modifying the one that doesn;t show without success).

I even checked in adwords editor to make sure there wasn't something I was missing in the new interface.

11:43 pm on Jan 12, 2010 (gmt 0)

Full Member

5+ Year Member

joined:Aug 28, 2007
posts:248
votes: 0


Are you using keywords together with placement targeting? I'm assuming you are or there wouldn't be any need for multiple adgroups? If so, then probably no displays are triggered for those keywords. If not, please elaborate a little on why you're using multiple adgroups to target the same site...

and my I venture a guess that $#*$!#*$!xx = 1? :)

 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members