Welcome to WebmasterWorld Guest from 54.198.90.50

Forum Moderators: buckworks & eWhisper & skibum

Message Too Old, No Replies

Adwords Slow Again

same thing last week

     
4:44 pm on Mar 9, 2009 (gmt 0)

New User

5+ Year Member

joined:Feb 23, 2009
posts:8
votes: 0


my online Adwords interface is painfully slow this morning while all other sites appear normal.

Adwords Editor seems slow as well.

Didn't the same thing happen last week?

I'm emailing rep.

Anyone else?

Ideas to fix?

3:06 pm on Mar 16, 2009 (gmt 0)

Full Member

5+ Year Member

joined:Aug 29, 2006
posts:205
votes: 0


Today the online interface is again very very slow. I have to wait about 30 seconds before a page loads. Frustrating...

Other websites are working fine so it is not a problem with my internetconnection.

12:37 am on Mar 20, 2009 (gmt 0)

Senior Member

WebmasterWorld Senior Member adwordsadvisor is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:July 9, 2003
posts:4799
votes: 0


Dclocks, I have not been hearing this said elsewhere - and this seems to be borne out by the lack of response from others in this rather busy forum who are experiencing the same thing.

In my experience, this sort of thing may respond to some simple 'fixes' such as the following - which are not sequential, by the way:

* Rebooting your computer if your rarely do that. (It astonishes me, sometimes, what this will set right.)

* Closing all your browser windows and opening a new one

* Possibly clearing cache and cookies.

* Not going to AdWords via a book mark - but by opening a new browser window and getting to the login page by typing in the URL

* Trying a different browser.

* Updating your current browser to the most recent version if you are using an older version.

* Trying a different computer if you have one available to you.

AWA

4:56 pm on Mar 23, 2009 (gmt 0)

New User

10+ Year Member

joined:Nov 28, 2005
posts: 40
votes: 0


I'm having extreme slowness in the Adwords online interface again today as well (had this problem last week too).

AWA, I'll try your suggestions, but they didn't work last week. Eventually last week the problem rectified itself.

Please check with your IT team.

Thx

11:20 pm on Mar 25, 2009 (gmt 0)

Full Member

5+ Year Member

joined:Aug 29, 2006
posts:205
votes: 0


* Closing all your browser windows and opening a new one
Thanks for the tips! I noticed this tip is working when I encounter a slow online interface. I'm using IE8 and closing the tab and open a new one (instead of closing the whole browser) is also working for me.
 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members