Welcome to WebmasterWorld Guest from 3.85.214.0

Forum Moderators: Ocean10000 & phranque

Message Too Old, No Replies

SSL problem

Something to do with Apache or Cobalt?

     
8:38 am on Nov 29, 2003 (gmt 0)

New User

10+ Year Member

joined:May 7, 2003
posts:19
votes: 0


Hi

I am having difficulty getting SSL to work on a Cobalt RAQ4 with OpenSSL and mod_ssl.

I tried to use the built in Cobalt method but all this appears to do is crash both Apache and the mailserver too.

So, I tried doing everything manually.
The httpd.conf looks something like this...

# global ssl setup
<IfModule mod_ssl.c>
SSLSessionCache dbm:/var/log/httpd/ssl_scache
SSLSessionCacheTimeout 300
SSLMutex file:/var/log/httpd/ssl_mutex
SSLRandomSeed startup file:/dev/urandom 512
SSLRandomSeed connect builtin
</IfModule>

Listen IPaddress:443

<VirtualHost www.widgetwidgets.com:443>
SSLEnable
SSLEngine on
SSLCertificateFile /home/sites/site3/certs/certificate
SSLCertificateKeyFile /home/sites/site3/certs/key
SSLSessionCacheTimeout 600
SSLLogFile /home/sites/site3/ssl.log
</VirtualHost>

Apache is running quite happily and not reporting any errors but if I try to access HTTPS I get the "page is unavailbe" message.

I've tried putting DocumentRoot in the VirtualHost but this makes no difference.

Any help would be most appreciated!

7:40 pm on Dec 2, 2003 (gmt 0)

Senior Member

WebmasterWorld Senior Member jdmorgan is a WebmasterWorld Top Contributor of All Time 10+ Year Member

joined:Mar 31, 2002
posts:25430
votes: 0


Can anybody help KennyJ out here?
<bump>