Welcome to WebmasterWorld Guest from 54.145.39.186

Forum Moderators: Ocean10000 & incrediBILL & phranque

Message Too Old, No Replies

apache 2 new install

my images won't load?

     

jamie

9:21 am on May 8, 2004 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



hi just set up apache 2 for the first time (redhat enterprise, everything by rpm) and my images won't load?

i have created a simple html file with a logo in it, but although i can see the title of the page and view source correctly, the image just won't load. the paths are correct.

is there some content setting i have to change?

much appreciate the help

added: i have just seen the following in the error_log

Permission denied: file permissions deny server access: /var/www/sites/mysite/htdocs/logo_big.gif

and am not sure what it refers to

Nick_W

9:31 am on May 8, 2004 (gmt 0)

WebmasterWorld Senior Member nick_w is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Check the permissions of that directory and the images. If you created the dir or images as root, you prolly dont have the correct perms on them...

chmod -R 755 /var/www/sites/mysite/htdocs/

Should do it I think...

Nick

jamie

11:14 am on May 8, 2004 (gmt 0)

WebmasterWorld Senior Member 10+ Year Member



hi nick,

thanks - it was exactly that :-)

and there i was thinking i was a bit of a *nix guru - lol

Nick_W

11:17 am on May 8, 2004 (gmt 0)

WebmasterWorld Senior Member nick_w is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Cool!

You might need to change ownership also, if you wish to edit files etc in that dir as your normal user: chown -R username /dir

Nick

 

Featured Threads

Hot Threads This Week

Hot Threads This Month