Welcome to WebmasterWorld Guest from 3.209.80.87

Forum Moderators: travelin cat

Message Too Old, No Replies

Trouble installing MySQL on OS X 10.2.8

Crashing sucks. :P

     
12:54 am on Feb 5, 2006 (gmt 0)

New User

10+ Year Member

joined:Feb 5, 2006
posts:5
votes: 0


Hello, I'm having some trouble installing MySQL 4.0.26 Standard onto my computer. I'm currently running Mac OS X 10.2.8 ("Jaguar") and the MySQL site says I can install it if I use their .pkg installer, so I did. But, as soon as the installation finishes, I get a crash report in multiple windows. They are as follows:

In the my_print_defaults.crash.log:


**********

Date/Time: 2006-02-04 19:51:51 -0500
OS Version: 10.2.8 (Build 6R73)
Host: cpe-65-189-160-223.columbus.res.rr.com

Command: my_print_defaults
PID: 1140

Exception: EXC_BREAKPOINT (0x0006)
Code[0]: 0x00000001Code[1]: 0x8fe01220

Thread 0 Crashed:
#0 0x8fe01220 in halt
#1 0x8fe10654 in link_in_need_modules
#2 0x8fe10270 in bind_lazy_symbol_reference
#3 0x8fe00e60 in stub_binding_helper_interface
#4 0x000083f0 in 0x83f0
#5 0x00008718 in 0x8718
#6 0x00006218 in 0x6218
#7 0x00002fcc in 0x2fcc
#8 0x00002ec4 in 0x2ec4
#9 0x00002bbc in 0x2bbc
#10 0x0000282c in 0x282c
#11 0x00001f74 in 0x1f74
#12 0x8fe190f4 in _dyld_start

PPC Thread State:
srr0: 0x8fe01220 srr1: 0x0002f030 vrsave: 0x00000000
xer: 0x20000000 lr: 0x8fe09bd8 ctr: 0x8fe293ac mq: 0x00000000
r0: 0x00000004 r1: 0xbfffdc70 r2: 0x8fe0b794 r3: 0x0000009d
r4: 0x00000000 r5: 0x0000009d r6: 0x0000000a r7: 0x2e64796c
r8: 0x2f6c6962 r9: 0x00000000 r10: 0x8fe4850c r11: 0x0000001a
r12: 0x8fe71ac4 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x00000000 r17: 0x00000000 r18: 0xbffffb60 r19: 0xbffffb70
r20: 0xbffffb40 r21: 0x00000000 r22: 0x00000000 r23: 0x0000e854
r24: 0xbfffe7d0 r25: 0x000224f4 r26: 0x000233d8 r27: 0x00023d2e
r28: 0x8fe4841c r29: 0x8fe484ec r30: 0x8fe484ec r31: 0x8fe0995c

In the mysqld.crash.log:


**********

Date/Time: 2006-02-04 19:51:54 -0500
OS Version: 10.2.8 (Build 6R73)
Host: cpe-65-189-160-223.columbus.res.rr.com

Command: mysqld
PID: 1144

Exception: EXC_BREAKPOINT (0x0006)
Code[0]: 0x00000001Code[1]: 0x8fe01220

Thread 0 Crashed:
#0 0x8fe01220 in halt
#1 0x8fe10654 in link_in_need_modules
#2 0x8fe10270 in bind_lazy_symbol_reference
#3 0x8fe00e60 in stub_binding_helper_interface
#4 0x0004dbdc in 0x4dbdc
#5 0x00002034 in 0x2034
#6 0x8fe190f4 in _dyld_start

PPC Thread State:
srr0: 0x8fe01220 srr1: 0x0002d030 vrsave: 0x00000000
xer: 0x20000000 lr: 0x8fe09bd8 ctr: 0x8fe293ac mq: 0x00000000
r0: 0x00000004 r1: 0xbffff760 r2: 0x8fe0b794 r3: 0x00000087
r4: 0x00000000 r5: 0x00000087 r6: 0x0000000a r7: 0x2e64796c
r8: 0x2f6c6962 r9: 0x00000000 r10: 0x8fe4850c r11: 0x0000001a
r12: 0x8fe71aae r13: 0x000001c0 r14: 0x002adb30 r15: 0x002adb30
r16: 0x002adb30 r17: 0x002adb30 r18: 0x002adb30 r19: 0x002bdb30
r20: 0x002adb30 r21: 0x00000000 r22: 0x00000000 r23: 0x00000000
r24: 0x00000000 r25: 0x002ac278 r26: 0x002c19b4 r27: 0x002c3c66
r28: 0x8fe4841c r29: 0x8fe484ec r30: 0x8fe484ec r31: 0x8fe0995c

Can someone tell me what the heck is going on?

8:05 pm on Feb 6, 2006 (gmt 0)

New User

10+ Year Member

joined:Feb 5, 2006
posts:5
votes: 0


I know you're out there... Hello?
2:42 pm on Feb 7, 2006 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member 10+ Year Member

joined:Aug 1, 2003
posts:815
votes: 0


Have you tried uninstalling and reinstalling?

(Warning: untested code -- use at own risk.)

cd /usr/local
sudo rm mysql*

(Then restart for good measure and run the installer again.)

Also, if you are using a binary MySQL installer, be sure you have the correct one for your version of MySQL. Or else, install from MySQL source.

2:43 am on Feb 9, 2006 (gmt 0)

New User

10+ Year Member

joined:Feb 5, 2006
posts:5
votes: 0


Erased all traces of MySQl. No problems so far. Then I tried to reinstall MySQL 4.0.26 and it crashed again. Here are the logs:

mysqld.crash.log:


**********

Date/Time: 2006-02-08 21:29:55 -0500
OS Version: 10.2.8 (Build 6R73)
Host: cpe-65-189-160-223.columbus.res.rr.com

Command: mysqld
PID: 783

Exception: EXC_BREAKPOINT (0x0006)
Code[0]: 0x00000001Code[1]: 0x8fe01220

Thread 0 Crashed:
#0 0x8fe01220 in halt
#1 0x8fe10654 in link_in_need_modules
#2 0x8fe10270 in bind_lazy_symbol_reference
#3 0x8fe00e60 in stub_binding_helper_interface
#4 0x0004dbdc in 0x4dbdc
#5 0x00002034 in 0x2034
#6 0x8fe190f4 in _dyld_start

PPC Thread State:
srr0: 0x8fe01220 srr1: 0x0002d030 vrsave: 0x00000000
xer: 0x20000000 lr: 0x8fe09bd8 ctr: 0x8fe293ac mq: 0x00000000
r0: 0x00000004 r1: 0xbffff760 r2: 0x8fe0b794 r3: 0x00000087
r4: 0x00000000 r5: 0x00000087 r6: 0x0000000a r7: 0x2e64796c
r8: 0x2f6c6962 r9: 0x00000000 r10: 0x8fe4850c r11: 0x0000001a
r12: 0x8fe71aae r13: 0x000001c0 r14: 0x002adb30 r15: 0x002adb30
r16: 0x002adb30 r17: 0x002adb30 r18: 0x002adb30 r19: 0x002bdb30
r20: 0x002adb30 r21: 0x00000000 r22: 0x00000000 r23: 0x00000000
r24: 0x00000000 r25: 0x002ac278 r26: 0x002c19b4 r27: 0x002c3c66
r28: 0x8fe4841c r29: 0x8fe484ec r30: 0x8fe484ec r31: 0x8fe0995c

my_prints_default.crash.log:


**********

Date/Time: 2006-02-08 21:29:52 -0500
OS Version: 10.2.8 (Build 6R73)
Host: cpe-65-189-160-223.columbus.res.rr.com

Command: my_print_defaults
PID: 779

Exception: EXC_BREAKPOINT (0x0006)
Code[0]: 0x00000001Code[1]: 0x8fe01220

Thread 0 Crashed:
#0 0x8fe01220 in halt
#1 0x8fe10654 in link_in_need_modules
#2 0x8fe10270 in bind_lazy_symbol_reference
#3 0x8fe00e60 in stub_binding_helper_interface
#4 0x000083f0 in 0x83f0
#5 0x00008718 in 0x8718
#6 0x00006218 in 0x6218
#7 0x00002fcc in 0x2fcc
#8 0x00002ec4 in 0x2ec4
#9 0x00002bbc in 0x2bbc
#10 0x0000282c in 0x282c
#11 0x00001f74 in 0x1f74
#12 0x8fe190f4 in _dyld_start

PPC Thread State:
srr0: 0x8fe01220 srr1: 0x0002f030 vrsave: 0x00000000
xer: 0x20000000 lr: 0x8fe09bd8 ctr: 0x8fe293ac mq: 0x00000000
r0: 0x00000004 r1: 0xbfffdc70 r2: 0x8fe0b794 r3: 0x0000009d
r4: 0x00000000 r5: 0x0000009d r6: 0x0000000a r7: 0x2e64796c
r8: 0x2f6c6962 r9: 0x00000000 r10: 0x8fe4850c r11: 0x0000001a
r12: 0x8fe71ac4 r13: 0x00000000 r14: 0x00000000 r15: 0x00000000
r16: 0x00000000 r17: 0x00000000 r18: 0xbffffb60 r19: 0xbffffb70
r20: 0xbffffb40 r21: 0x00000000 r22: 0x00000000 r23: 0x0000e854
r24: 0xbfffe7d0 r25: 0x000224f4 r26: 0x000233d8 r27: 0x00023d2e
r28: 0x8fe4841c r29: 0x8fe484ec r30: 0x8fe484ec r31: 0x8fe0995c

3:36 am on Feb 11, 2006 (gmt 0)

Senior Member from US 

WebmasterWorld Senior Member 10+ Year Member

joined:Aug 1, 2003
posts:815
votes: 0


Hello again. Looking back at my previous post, I see I mis-typed an important point: I meant to say to make sure the MySQL binary worked for your version of OS X.

Unfortunately, this is tricky because MySQL's older downloads page doesn't mention versions of OS X, but rather Darwin.

It looks like the MySQL binary you need is called:
mysql-standard-4.0.26-apple-darwin6.8-powerpc.tar.gz

Make sure you're not using:
mysql-standard-4.0.26-apple-darwin7.9.0-powerpc.tar.gz

You can match Darwin versions to OS X versions here:
[opensource.apple.com ]

Sorry for not being clear before. Please let us know if that helps.

1:28 am on Feb 12, 2006 (gmt 0)

New User

10+ Year Member

joined:Feb 5, 2006
posts:5
votes: 0


D'OHHHHH! *echoes for miles*