Welcome to WebmasterWorld Guest from 54.147.10.12

Forum Moderators: brotherhood of lan & mack

Message Too Old, No Replies

php includes don't show up locally

but they show up online

     
5:11 am on Jun 4, 2004 (gmt 0)

Junior Member

10+ Year Member

joined:Apr 14, 2004
posts:44
votes: 0


I have a site that uses php includes, but the php includes won't show on my computer. Each individual php file does show up, just not as an include. I thought this was the same type of installation I used before I reinstalled windows so I'm not sure what I did different. I know they used to work. Any ideas what could cause this?
8:40 am on June 4, 2004 (gmt 0)

Administrator from JP 

WebmasterWorld Administrator bill is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:Oct 12, 2000
posts:14487
votes: 49


It helps if you have PHP and a server installed on your local machine.
10:27 am on June 4, 2004 (gmt 0)

Junior Member

10+ Year Member

joined:Apr 14, 2004
posts:44
votes: 0


I already have php/apache/sql installed on my computer. My computer says that the apache service has started. I can read the php files locally (which it wouldn't do before), just not the includes. I might have done something wrong during installation so I'll try reinstalling again. Just wondering if anyone knew if I could have done something wrong in the config that would cause a problem like this.
12:25 pm on June 4, 2004 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:July 11, 2003
posts:955
votes: 0


search for "php includes not working" in Google.

:)

Sid

[edited by: mack at 8:55 pm (utc) on June 4, 2004]
[edit reason] Removed URL [/edit]

1:42 am on June 5, 2004 (gmt 0)

Moderator This Forum from GB 

WebmasterWorld Administrator mack is a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month

joined:June 15, 2001
posts:7557
votes: 3


Are you getting any form of error massage where your include should be or nothing at all?

I know you will have checked this but are you using the correct syntax for your includes?

Mack.

10:30 pm on June 6, 2004 (gmt 0)

Junior Member

10+ Year Member

joined:Apr 14, 2004
posts:44
votes: 0


Mack - no errors at all. The includes just didn't show. Some php scripts worked, others didn't. Apache service was started. I think it was something about the way I set it up because a few reinstallations later using different setup files, it worked. Weird, I could have sworn I used the same setup file before I reinstalled windows.