Welcome to WebmasterWorld Guest from 54.221.30.139

Forum Moderators: bakedjake

Message Too Old, No Replies

Anchor Links Don't Work on Some PDAs

dedicated AvantGo channel

     

kevinj

3:36 pm on Dec 8, 2002 (gmt 0)

10+ Year Member



I have developed a simple HTML conference schedule for a client and have created an AvantGo channel for users to put the schedule on a PDA. I just heard from a user that the anchor links I've created on the page do not work on his Handspring Visor or Palm 105. They work fine on my Palm III and Toshiba Pocket PC. I believe it's an issue with how I created the links. Ex.

<a href="pdaschedule.html#monday>Monday</a>

Does anyone have an idea what the problem might be? Do I need to change the link, add an "/" before the name of the page?

I'm at a loss. Thanks for any help.

korkus2000

1:21 pm on Dec 9, 2002 (gmt 0)

WebmasterWorld Senior Member korkus2000 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



So are the anchor links not scrolling on those handhelds? Are they reloading the page?

kevinj

2:53 pm on Dec 9, 2002 (gmt 0)

10+ Year Member



This is what the user just emailed me about what happens when he clicks on an anchor link:

When I click on a day, the page quickly redraws (looks like the screen flashes). Otherwise nothing happens. All of the "Top of Page" links send me to the very beginning. Also, the days of the week links at the very bottom, also send me to the top. It acts like all of the links are assigned to the very top of the document.

korkus2000

2:56 pm on Dec 9, 2002 (gmt 0)

WebmasterWorld Senior Member korkus2000 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



This may just be a mistype, but are you closing the "" in the tag?

<a href="pdaschedule.html#monday>Monday</a>

should be

<a href="pdaschedule.html#monday">Monday</a>

Can you copy and past a link from the page.

kevinj

3:04 pm on Dec 9, 2002 (gmt 0)

10+ Year Member



Sorry, that was a mistype. Here's a link copied directly from the page:

<a href="pdaschedule.html#monday">Monday</a>

korkus2000

3:10 pm on Dec 9, 2002 (gmt 0)

WebmasterWorld Senior Member korkus2000 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Can you copy an paste the anchor it goes to

<a name="">

Just trying to narrow it down.

kevinj

3:16 pm on Dec 9, 2002 (gmt 0)

10+ Year Member



<a name="monday"></a>
<b>Monday, December 16</b>

korkus2000

3:18 pm on Dec 9, 2002 (gmt 0)

WebmasterWorld Senior Member korkus2000 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



What browser software is being used on the palm 105, visor, and the ones that do work?

kevinj

3:22 pm on Dec 9, 2002 (gmt 0)

10+ Year Member



It's all AvantGo Connect that allows the page to be viewed. For the Visor and Palms it's probably Palm OS 4.x. I have a Palm III that the links work on, and on my Toshiba that works, it's Windows CE.

korkus2000

3:26 pm on Dec 9, 2002 (gmt 0)

WebmasterWorld Senior Member korkus2000 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



Here is something I found. I don't know if it helps
[ourworld.compuserve.com...]

...still digging

korkus2000

3:47 pm on Dec 9, 2002 (gmt 0)

WebmasterWorld Senior Member korkus2000 is a WebmasterWorld Top Contributor of All Time 10+ Year Member



I can't find anything else. Hopefully someone else may have more insight. Have you tried contacting aventgo. You may get more info from them.

kevinj

6:34 pm on Dec 9, 2002 (gmt 0)

10+ Year Member



Thanks Korkus for all your help, that link you gave me at least gives me a lead to pursue. Strange that it works on some but not on others. Any other thoughts anyone?
 

Featured Threads

Hot Threads This Week

Hot Threads This Month