Welcome to WebmasterWorld Guest from 34.225.194.144

Forum Moderators: bakedjake

Message Too Old, No Replies

Spooky Sendmail

A strange is happening!

     

robb1020

8:38 am on Apr 6, 2006 (gmt 0)

Inactive Member
Account Expired

 
 


I have configured, successfully, Sendmail 8.12 on my SuSE 9.2 cluster (can't afford SLES). I can send and receive e-mails directly without having to use my 'USELESS' (sorry, didn't mean to shout, just had so much hassle with them recently, which is what prompted me to run my own web services - it's still rather raw, forgive me)ISP. However, my 'test' chums are reporting that my e-mail From: field is appended with the host name of one of my servers. I have checked sendmail.cf and applied the usual Cw and DM prefixes to try and stop this. I have sorted the Virtusertable and placed the appropriate entries in the hosts file. I have also checked the voracity of Access, Aliases, Local_Host_Names, and I've given my DNS server configuration files a damn good seeing to. Everything seems okay. That fact that mail is to-ing and fro-ing tells me that the service is fine.

So, wise ones, why and what is appending the sender's address with the host name of one of the cluster servers?

Oh, yes, I did stop Heartbeat and run a server in isolation, the problem persisted.

Look forward to a complete solution from better men than me.

7:15 pm on Apr 10, 2006 (gmt 0)

New User

10+ Year Member

joined:Mar 30, 2006
posts:12
votes: 0


/etc/hosts possibly

Find WHERE the hostname is by either pinging other devices (In the case of a relay) or using uname to find it locally...

You may also like postfix or another MTA to sendmail, Ive never like it...

 

Join The Conversation

Moderators and Top Contributors

Hot Threads This Week

Featured Threads

Free SEO Tools

Hire Expert Members