Welcome to WebmasterWorld Guest from 54.147.189.54

Forum Moderators: bakedjake

Message Too Old, No Replies

IXQUICK not working?

     
12:06 am on Oct 26, 2003 (gmt 0)

Full Member

10+ Year Member

joined:Dec 30, 2002
posts:295
votes: 0


[ixquick.com...] doesn't seem to be retriving results from most engines just Overture and Looksmart? Anyone know why?
12:48 am on Oct 26, 2003 (gmt 0)

Full Member

joined:Dec 13, 2002
posts:314
votes: 0


It's only showing results from the paid search engines because they have gone from offering a nice meta search engine to paid results via their partnerships with the $$ search engines. Kind of like a prostitute which is what they are now. I really used to like ixquick, now it's no better then one of those fake "search engines" you see all the time. = junk.
1:05 am on Oct 26, 2003 (gmt 0)

Full Member

10+ Year Member

joined:Dec 30, 2002
posts:295
votes: 0


Seems strange as they still have the other engines at the top of their page but they don't retrieve from them.
If that's what they have done they won't last much longer, a shame really, I used to use them quite a bit, now it's useless.
8:20 am on Oct 26, 2003 (gmt 0)

New User

10+ Year Member

joined:Oct 24, 2003
posts:3
votes: 0


they seem to have come online but no results yet.
8:26 am on Oct 26, 2003 (gmt 0)

Senior Member

WebmasterWorld Senior Member 10+ Year Member

joined:May 5, 2002
posts:825
votes: 0


The last time I used Ixquick (a few days ago) they were displaying sponsored/paid results on the first page and then the meta search results beginning on page 2.