Welcome to WebmasterWorld Guest from

Forum Moderators: werty

Message Too Old, No Replies

Adcenter: Signup Errors: Mac Users

on mac OSX and tried all my browsers and got errors.



1:46 am on Jul 6, 2006 (gmt 0)

10+ Year Member

Just spent two hours trying to sign up. I am a mac user OSX 10.3.9


1. Opera: Got tot he billing section then on submit got error -1

2. Safari: Microsoft adCenter does not currently support the web browser you are using. Please sign in using Internet Explorer 6+. More about system requirements

3. Firefox Next button just hangs.

4. IE 5 (no IE 6 for mac) No luck.

5. IE 5 using virtual PC windows 2000 (IE6 is for windows Xp). It kept asking me over and over for providence/state when I had Nevada selected.

So after 2 hours and sore wrists Nothing.

How hard is it to intsall a signup form that works in most browsers? I can only imagine the headaches I will face once I signup through a customer rep and have to admin the bids and keywords etc..

Should I pursue this?


12:19 am on Jul 7, 2006 (gmt 0)

5+ Year Member

Although the traffic is significantly smaller then Google, and slightly less than Yahoo, I find it's more reliable. To every man (or woman) their own, the only way to know is to try it out. More traffic is usually better...

PS - Want the headaches to cease? Try Bootcamp (Although you'll have to buy XP)

www (dot) apple (dot) com (slash) macosx (slash) bootcamp

You can thank an old WW post for that one! ;)


8:03 pm on Jul 7, 2006 (gmt 0)

10+ Year Member

So I finally found a buddy who would sign me up via IE 6+/ XP

ANd I am signed up.

Now I am unable to create any campaigns in any browser. Firefox comes close.

I called customer service, they said they are aware of this, and may get fixed in new update.

They told me to post here and maybe adcenter411 will respond...


7:20 am on Jul 15, 2006 (gmt 0)

10+ Year Member

adcenter 411 when will there be a firefox update so mac users can admin their accounts?


7:24 am on Jul 16, 2006 (gmt 0)

10+ Year Member

Just installed Flock, and it too hangs on step 1 for creating campaigns.
Honestly, I don't know if your engineers tried purposely to be so retarded in creating an interface that would work with 1 browser, honestly you have to be really retarded to create HTMl code that would only work on IE 6+ XP..my god, man, who made that decision..... I've never seen anything like this before, there is absoultely no Freakin way to admin adcenter via a mac, unless it's firefox which you say is coming at summers end?...and we have to wait till end of summer//if I was project manager I'd fire all those turds who develped this hunka crap.... One day, I could develop you a form in php that would work in all browsers

honestlky adcenter, it's freakin 2006, your interface wont work in anything but IE 6+? #*$!?

retards...you deserve that comment.....absoultely retards....in your html dept.


11:25 pm on Jul 16, 2006 (gmt 0)

10+ Year Member

ONe more thing....

Fired up virtual PC and installed Firefox and instaled the IE Tab extension.

It did not work.

Unbelievable. It really is.... shame on your developers....honestly...,shame on you guys...


Featured Threads

Hot Threads This Week

Hot Threads This Month