Welcome to WebmasterWorld Guest from

Forum Moderators: not2easy

Message Too Old, No Replies

Div with UL not floating left or removing bullets



9:23 pm on Oct 29, 2008 (gmt 0)

5+ Year Member

I am trying to create a horizontal nav bar in the div "bot-nav". When I try applying bullet style-none and float left (to get the list horizontal), nothing happens. I'd appreciate it if someone would take a look and see if they could help me out. Thanks

@charset "utf-8";
body {
margin: 0;
padding: 0;
background: #000000;
text-align: center;
font-family: Verdana, Arial, Helvetica, sans-serif;
#wrapper {
background: #E1CC95;
height: 708px;
width: 900px;
position: relative;
margin: 20px auto;
#maincontent {
#header {
background: url(images/slices/header-bk.jpg) no-repeat;
height: 123px;
width: 900px;
#maincontent {
#feature {
height: 361px;
width: 707px;
background: url(images/slices/rack-feature.jpg) no-repeat;
text-align: left;
#rck_feature {
color: #F6CE6E;
text-decoration: none;
height: 265px;
width: 215px;
margin-top: 80px;
margin-left: 30px;
font: normal 11px Verdana, Arial, Helvetica, sans-serif;
padding-top: 13px;
#buttons3 {
height: 361px;
width: 193px;
background: url(images/slices/buttons3.gif) no-repeat;
position: relative;
.link_bullet {
font-family: Verdana, Arial, Helvetica, sans-serif;
background: #FFFFFF;
#copy-3 {
background: url(images/slices/3-copy.jpg) no-repeat;
height: 161px;
width: 900px;
#bot-nav {
background: url(images/slices/bot-nav.gif) no-repeat;
height: 41px;
width: 900px;
font: bold 14px Verdana, Arial, Helvetica, sans-serif;
color: F6CE6E;
list-style: none;
text-decoration: none;
#foot-bot {
background: url(images/slices/foot-bot.jpg);
height: 23px;
width: 900px;
#bullet-1 {
height: 12px;
position: absolute;
top: 80px;
color: #0099CC;
font: bold 12px Verdana, Arial, Helvetica, sans-serif;
vertical-align: middle;
left: 36px;
.fltrt {
float: right;
.fltlft {
float: left;
.clrflt {
clear: both;

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />


<link href="../Saxstorage/sax-style.css" rel="stylesheet" type="text/css" />
<div id="wrapper">
<div id="header"></div>
<!-- TemplateBeginEditable name="main" -->
<div id="maincontent"></div>
<!-- TemplateEndEditable -->
<div id="bot-nav">
<div id="foot-bot"></div>


9:51 pm on Oct 29, 2008 (gmt 0)

5+ Year Member

the only thing in the css that is floating left is class="fltlft" which isn't in the html code, so maybe you forgot some tags or you are doing something wrong ;)


11:27 pm on Oct 29, 2008 (gmt 0)

5+ Year Member

Thanks for the reply. I don't know what happened. Possibly I had a different style sheet up when I copied.
I have that working however I'm running into a float clearing problem so I'm posting a separate thread.

Featured Threads

Hot Threads This Week

Hot Threads This Month