Welcome to WebmasterWorld Guest from

Forum Moderators: Ocean10000 & incrediBILL & phranque

Message Too Old, No Replies

Very strange behaviour of Apache - - Help needed



8:48 pm on Oct 26, 2006 (gmt 0)

10+ Year Member

Hi there,

I have website with lots of photo galleries of cars.
After moving to a better server 2 weeks ago, I now noticed that the main gallery pages which include 30 thumbnails of about 2k in size are not being served properly.
In fact, the very strange behaviour of Apache (that's what I guess) is like that:

You hit page 1 - Response is fast, the page loads first, then the 30 thumbnails are loaded very fast one by one... No problem...

You hit page 2 - Response is fast, the page loads, the 30 thumbnails are loaded very fast one by one... Again no problem...

** Page 3 - You hit page 3... The first 5-6 thumbnail is served.. Then the page hangs about 3 seconds.. 3-4 more thumbnails are served, then hangs another 3 seconds... 3 more served, then hangs another 3 secs.. Hit another page - Hangs 3 seconds... What the heck is this?

I have everything in httpd.conf normal.
Keepalive on
Keepalive timeout 15
Max Keepalive requests 1000 (tried 5000)
Tried max keepalive reqs 0, keepalive timeout 200... No change...
I have min spare servers 15 everytime, 2 gig RAM and the server load is normal...

What may be the reason for this?

Edit: When you stuck like that, wait about half a minute and you start from the beginning: Very fast load of the first 2 pages, then again you stuck at page 3... About 100'th request made in the connection... Strange...


Featured Threads

Hot Threads This Week

Hot Threads This Month