homepage Welcome to WebmasterWorld Guest from 174.129.163.183
register, free tools, login, search, subscribe, help, library, announcements, recent posts, open posts,
Subscribe and Support WebmasterWorld
Home / Forums Index / Code, Content, and Presentation / XML Development
Forum Library, Charter, Moderators: httpwebwitch

XML Development Forum

    
Error Even With Validated Sitemap
andrewshim




msg:3428589
 6:06 am on Aug 22, 2007 (gmt 0)

I encountered errors in my sitemap :

Network unreachable: robots.txt unreachable
We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit. [?]

I validated my sitemap with 2 tools and they seem to be okay. Sample of sitemap follows :

<?xml version="1.0" encoding="UTF-8"?>
<urlset
xmlns="http://www.google.com/schemas/sitemap/0.84"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://www.google.com/schemas/sitemap/0.84 [google.com...]

<url>
<loc>http://www.example.com/</loc>
<changefreq>daily</changefreq>
<priority>1.00</priority>
</url>

<url>
<loc>http://www.example.com/sitemap.php</loc>
<changefreq>daily</changefreq>
<priority>1.0</priority>
</url>

<url>
<loc>http://www.example.com/learningCenter.php</loc>
<changefreq>weekly</changefreq>
<priority>0.9</priority>
</url>

Checking with my webhost, and my logs, I don't find any bot has been denied access, but Googlebot has stopped downloading my robots.txt and stopped crawling my site.

Is this error caused by my webhost blocking (unintentionally)?

Is the sitemap.php (used for regular visitors viewing) being confused as the sitemap.xml by google?

Should I remove my sitemap.xml altogether?

 

cmarshall




msg:3428708
 10:28 am on Aug 22, 2007 (gmt 0)

I am not a sitemap expert, but all a validation will tell you is that the XML is well-formed and conforms to a schema.

It sounds like your problem is actually with the contents of the sitemap. I'm guessing that the embedded URI points to a page/site that does not meet some follow-through requirement. Maybe the URI itself has a problem, or the robots.txt file has issues. I dunno.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / XML Development
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About
© Webmaster World 1996-2014 all rights reserved