homepage Welcome to WebmasterWorld Guest from 54.196.122.247
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member
Home / Forums Index / Code, Content, and Presentation / RSS, ATOM, and Related Technologies
Forum Library, Charter, Moderators: bill & werty

RSS, ATOM, and Related Technologies Forum

    
XML Parsing Error for RSS Feed
Ahkamden




msg:3584533
 2:09 am on Feb 26, 2008 (gmt 0)

I'm currently using Joomla with a WP port for a component. And sorry not sure if this should go under RSS or XML

My RSS feed shows this error
XML Parsing Error: junk after document element
Location: h ttp://sitename.com/index.php?option=com_mojo&Itemid=**&feed=rss2(broke link on purpose)
Line Number 2, Column 1:
<?xml version="1.0" encoding="UTF-8"?>

But I really think the error is caused from
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://sitename.com/components/com_mojo/xmlrpc.php?rsd" />
Which is the first line. So I'm just asking for general suggestions if anyone can point me in the right direction.

I talked to the component maker and he states that it only shows up if someone is logged in frontend/backend. But I've gone through and repeatedly verified no one is.

And I've visited other sites using same component that have it working OK.

Any help is greatly appreciated!

 

bill




msg:3584544
 2:20 am on Feb 26, 2008 (gmt 0)

Where and when are you getting this error?

Ahkamden




msg:3584548
 2:30 am on Feb 26, 2008 (gmt 0)

Thanks for quick reply bill,

I receive this error when I click on the feed for the blog.

bill




msg:3584637
 4:13 am on Feb 26, 2008 (gmt 0)

From a browser, or from somewhere within your CMS?

Does your feed itself validate? [validator.w3.org...]

Ahkamden




msg:3585019
 2:42 pm on Feb 26, 2008 (gmt 0)

No it does not, I get

Undefined root element: link

For the EditURI, and this is when I click on 'entries' from the browser. Instead of showing the postings formatted it gives the error

bill




msg:3585551
 10:56 pm on Feb 26, 2008 (gmt 0)

So this is a Joomla issue? If so I'm not going to be much help. You'd have better luck asking the Joomla community or support about that.

The only thing I could suggest if this is an RSS issue would be to find the template for your feed and see if you can fix that.

Ahkamden




msg:3585608
 11:51 pm on Feb 26, 2008 (gmt 0)

Well I believe it's a component issue. But was hoping that EditURI line might be generic enough someone would have some feedback. Cause I'm not sure what would happen if I just edit it. And the joomla community won't know much about just this component so it's like a catch 22.

Thanks though!

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / RSS, ATOM, and Related Technologies
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved