homepage Welcome to WebmasterWorld Guest from 54.196.159.11
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Search Engines / Sitemaps, Meta Data, and robots.txt
Forum Library, Charter, Moderators: goodroi

Sitemaps, Meta Data, and robots.txt Forum

    
Custom and generated sitemap both fail on Google Webmaster Tools
sitemap failure google webmaster tools
thewpfan




msg:4207563
 4:05 pm on Sep 27, 2010 (gmt 0)

I tried creating my own sitemap.xml using sitemap.org and google`s guidelines, but got the "X" on Google Webmaster Tools (GWT).

I decided to use Google XML Sitemap`s plugin by Arne Brachhold, but am still getting the "X" on GWT.

I submitted both urls to google and added them to GWT as follows:
www.example.jp
example.jp

However, I am still getting the "X" on GWT for both urls.

The sitemap is on:
example.jp/news/sitemap.xml

If anyone has ideas on what may be causing the problem, I would highly appreciate it.

Thank you!

[edited by: goodroi at 12:25 pm (utc) on Sep 28, 2010]
[edit reason] examplified [/edit]

 

Propools




msg:4207570
 4:25 pm on Sep 27, 2010 (gmt 0)

The first thing I would ask is to make certain the sitemap is in the directory which G thinks it is and that it's not blocked by the robots file ?

I get a 404 error when I try to see the sitemap.xml on the root of example.jp

[edited by: goodroi at 12:30 pm (utc) on Sep 28, 2010]
[edit reason] examplified [/edit]

LifeinAsia




msg:4207577
 4:35 pm on Sep 27, 2010 (gmt 0)

I was able to see the file in the sub-directory. Some comments:
1) Did you try validating them?
2) I'm not sure you can actually include comments in sitemap files (lines 2 & 3).
3) You may want to take out the time components of the <lastmod> nodes.

thewpfan




msg:4207587
 5:00 pm on Sep 27, 2010 (gmt 0)

@Propools
I have specified in G that the sitemap is in /news/sitemap.xml
The sitemap is visible when going to example.jp/news/sitemap.xml

@LifeinAsia
1. Is this link a sufficient validator [w3.org...]
2. I took out lines 2 & 3
3. I also took out <lastmod> nodes even though it is highly recommended

I have resubmitted the file to GWT

[edited by: goodroi at 12:27 pm (utc) on Sep 28, 2010]
[edit reason] examplified [/edit]

thewpfan




msg:4208143
 2:43 pm on Sep 28, 2010 (gmt 0)

Hi guys,

I have reverted back to creating two sitemaps (one for www and one without) using google guidelines and sitemaps.org. I get the check successful and then after about 6 hours I get the X again.

My sitemaps are here. Any ideas what may be causing the problem?

example.jp/sitemap.xml
example.jp/sitemapwww.xml

[edited by: goodroi at 8:24 pm (utc) on Sep 28, 2010]
[edit reason] Please stop posting links to your own site [/edit]

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Search Engines / Sitemaps, Meta Data, and robots.txt
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved