homepage Welcome to WebmasterWorld Guest from 54.235.61.62
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member
Home / Forums Index / Search Engines / Sitemaps, Meta Data, and robots.txt
Forum Library, Charter, Moderators: goodroi

Sitemaps, Meta Data, and robots.txt Forum

    
Including Images in Sitemaps - XML Parsing
Hoegaarden




msg:4133936
 11:14 am on May 17, 2010 (gmt 0)

Has anyone tried adding images to a sitemap - [google.com ]

I've added some images to mine as Google's guideline suggests and I'm getting an xml parsing error when i try to view it in my browser (Firefox).

Anyone else also had any problems with this?

 

tedster




msg:4134153
 5:57 pm on May 17, 2010 (gmt 0)

Have you run your Sitemap.xml file through an XML validator?

goodroi




msg:4134638
 12:45 pm on May 18, 2010 (gmt 0)

sitemaps can be fragile. one typo can cause havoc. i'd follow tedster's advice and head over to a sitemap validator.

Hoegaarden




msg:4134715
 2:52 pm on May 18, 2010 (gmt 0)

Just ran it through a validator and it's showing the same error -

Error: Element name image:image has unbound prefix
in unnamed entity at line 17 char 14 of http://www.example.com/sitemap.xml

Line 17 is where the first <image:image> tag begins.

Hoegaarden




msg:4135787
 8:41 am on May 20, 2010 (gmt 0)

This has been resolved now.

I double checked everything and found that i didn't include this code in the urlset tag "xmlns:image="http://www.google.com/schemas/sitemap-image/1.1"

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Search Engines / Sitemaps, Meta Data, and robots.txt
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved