Matthew1980 - 5:51 pm on Dec 23, 2011 (gmt 0)
Thanks for letting me know that your code now functions as expected; wrt `` || '' this is just a preferential thing, I personally advocate this method of compatibility, and Rocknbil's explanation is correct (thanks for the clarity there Rocknbil) it's not generally needed it just provides the user with a way of making their code a little more versitile.
Though really when designing a DB you should try to name the column names pertinant to their purpose, I usually prefix them with the acronym of the project with a following underscore: MFP_date_timestamp - but habit is hard to break so I usually end up with this: `MFP_date_timestamp` <<My First Project.
But that example is just my preference, it's now upto you as to how you develop your programming style. As Rocknbil states "The correct answer is probably yes, but they are not really needed in most cases. "
Anyway, happy coding & seasons greetings too :)