homepage Welcome to WebmasterWorld Guest from 23.20.77.156
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Code, Content, and Presentation / PHP Server Side Scripting
Forum Library, Charter, Moderators: coopster & jatar k

PHP Server Side Scripting Forum

    
XAMPP on windows suddenly stopped working
php not working right anymore
rodriguez1804




msg:3902144
 5:37 am on Apr 28, 2009 (gmt 0)

Hey guys,

I was working on a php script about 3 days ago using XAMPP environment in windows xp - everything worked great, php displayed on browsers and all. Today, I tried to display the same script and all I see is a bunch of the php code on the browser window. I tried opening other php files and even did a simple echo "hello" and nothing! What may be the cause? #*$!! No viruses or anything of that sort either.

 

dreamcatcher




msg:3902986
 6:37 am on Apr 29, 2009 (gmt 0)

Has the apache server started ok?

dc

rodriguez1804




msg:3905380
 6:39 am on May 2, 2009 (gmt 0)

yeah, apache server starts ok and everything

rodriguez1804




msg:3905382
 6:45 am on May 2, 2009 (gmt 0)

ok, it tries to download the php file in the browser instead of displaying it. I remember it has to do something with editing the .htaccess file and putting something like addType x-http .html .php or something like this. Question is what file do I edit in xampp?

Update: I found I had already added this line to my httpd.conf file. So with this out of the question, what else could be the cause?

xKillswitchx




msg:3906909
 6:44 am on May 5, 2009 (gmt 0)

Skype, possibly, if you have it, or another program that may use internet connection and using port 80. When I installed Skype, Xampp stopped working, so I told Skype not to use port 80 and it worked again. Check any new program settings, or possibly even firewall settings.

steve




msg:3906965
 8:47 am on May 5, 2009 (gmt 0)

Have you installed any other software which may have in turn installed another server, or have you accidentally enabled IIS?

I keep a copy of XAMPP on a USB stick, which I move between machines. Could you copy your set up try and running it on another machine?

I all else fails back up your websites and try a reinstall.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / PHP Server Side Scripting
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved