homepage Welcome to WebmasterWorld Guest from 54.167.11.16
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Code, Content, and Presentation / PHP Server Side Scripting
Forum Library, Charter, Moderators: coopster & jatar k

PHP Server Side Scripting Forum

    
OSX 10.5.3 and PHP mail not working? Here's a fix
Worked on this for hours, finally found a solution.
quixotic




msg:3669327
 5:31 pm on Jun 7, 2008 (gmt 0)

I am not sure what changed in v10.5.3, but after updating, my PHP scripts would no longer send out mail, even though Apple mail was fine. Maybe a fluke, maybe note. But it looks like the domain names wouldn't resolve after the update. This fixed it:

Open up a terminal window

Type this:
sudo vi /etc/resolv.conf

add a couple of name servers

Save and exit.

Now try mailing again. I hope this saves someone a couple hours of frustration.

[edited by: coopster at 5:46 pm (utc) on June 7, 2008]
[edit reason] removed specific nameservers [/edit]

 

eelixduppy




msg:3671223
 2:17 pm on Jun 10, 2008 (gmt 0)

Thanks for sharing your solution. :)

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / PHP Server Side Scripting
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved