homepage Welcome to WebmasterWorld Guest from 54.235.36.164
register, free tools, login, search, subscribe, help, library, announcements, recent posts, open posts,
Subscribe to WebmasterWorld
Visit PubCon.com
Home / Forums Index / Code, Content, and Presentation / PHP Server Side Scripting
Forum Library, Charter, Moderators: coopster & jatar k

PHP Server Side Scripting Forum

    
php.ini for form captcha
php.ini for form captcha
drooh




msg:3322058
 4:04 am on Apr 26, 2007 (gmt 0)

I am trying to configure my php.ini to allow my form captcha to work. (basically the image is not showing up) I have the same php code working on my main paid server but I am having trouble on my home box.

Any ideas what I need to tweak in my php.ini settings?

 

capulet_x




msg:3322084
 4:45 am on Apr 26, 2007 (gmt 0)

Hmm is GD installed?

suzie250




msg:3322085
 4:46 am on Apr 26, 2007 (gmt 0)

I can't say what settings to check, but until someone else comes along that can...

You could check the php settings for each server to see what's set up differently.

If you're not sure how to do that, let me know and I'll post it here.

Suzie

drooh




msg:3322091
 4:56 am on Apr 26, 2007 (gmt 0)

what is GD?

suzie250




msg:3322096
 5:09 am on Apr 26, 2007 (gmt 0)

GD is an image library. [us2.php.net ]

capulet_x




msg:3322100
 5:18 am on Apr 26, 2007 (gmt 0)

Drooh,

use this script to get your setup info if you haven't already:

<? phpinfo();?>

open it from your paid server and a dublicate of it on your local server. The GD library may be on your paid server but not on your local server. If you don't have the BD library just download it as it is opensource. I don't think I can post links like that here but Google will hunt it down for you.

dreamcatcher




msg:3322153
 6:45 am on Apr 26, 2007 (gmt 0)

capulet_x,

Its not a problem linking to established open source projects like the GD library:

[libgd.org...]

dc

drooh




msg:3322167
 7:11 am on Apr 26, 2007 (gmt 0)

on my line 637 of php.ini
extension=php_gd2.dll

thats it!

btw, i think ZIP distribution of php 5.2.1 includes this, you just need to enable it in the php.ini

thanks to all!

fastburst




msg:3336280
 8:56 pm on May 10, 2007 (gmt 0)

I am having a problem with ANY captcha script

I am running PHP 5.2.1 and GD 2.1.9 is installed What could be causing this? I used WAMP for the install so is that helps out any.

drooh




msg:3336288
 9:02 pm on May 10, 2007 (gmt 0)

you may want to try searching for solmetra and they have a nice little captcha.

also you may need to modify your php.ini as shown in this post.

also may be helpful to post more info about your set up and your problem.

fastburst




msg:3336297
 9:05 pm on May 10, 2007 (gmt 0)

Do you have a direct link I searched and didnt see anything relative. Will this address the captcha issues? Ihave tried every captcha script I could find and could get any of the images to actually display.

drooh




msg:3336324
 9:18 pm on May 10, 2007 (gmt 0)

it is the 1st thing that comes up in google if you search for
solmetra

on their site they have a fomr captcha that works very well. it is the only one i use. i had problems emplemting it on my web server until i edited my php.ini file.

fastburst




msg:3336329
 9:28 pm on May 10, 2007 (gmt 0)

Okay I just installed it and I have the same problem as all the oherones, the image is not displaying, i get the red "x" any clues?

drooh




msg:3336587
 4:14 am on May 11, 2007 (gmt 0)


on my line 637 of php.ini
extension=php_gd2.dll

Is this a home server or paid web host?

Have you looked at your php info?

Have you read through this post?

Have you tried to modify your php.ini?

Can you post some code examples or your phpinfo
<?
phpinfo()
?>

fastburst




msg:3337001
 2:01 pm on May 11, 2007 (gmt 0)

I have that on my php.ini with gd enabled as the extension, my gd version is 2.1.9 and php 5.2.1 on a home server. Even on my paid server with ev1.net it is doing the same thing.

could it be a bad copy of the GD file?

drooh




msg:3337457
 9:06 pm on May 11, 2007 (gmt 0)

possibly, i know for me i used the exe version of php for my install then i had to get the zip file and just replace everything with it. then it seemed to work.

also have you tried xampp? (search for xampp apache friends)

i used to use it and by default most everything worked.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / PHP Server Side Scripting
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About
© Webmaster World 1996-2014 all rights reserved