homepage Welcome to WebmasterWorld Guest from 54.237.99.131
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member
Home / Forums Index / Code, Content, and Presentation / Perl Server Side CGI Scripting
Forum Library, Charter, Moderators: coopster & jatar k & phranque

Perl Server Side CGI Scripting Forum

    
Problem with Thread::Pool in Cygwin
Thread::Pool in Perl
manglesh



 
Msg#: 4327955 posted 12:08 pm on Jun 19, 2011 (gmt 0)

Hi Team

i am newbe with perl using Cygwin, while installing Module Thread::Pool i am getting below error.

i have tried below commnad to install.

1. perl -MCPAN -e 'install Thread::Pool'

Test Summary Report
-------------------
t/Pool01.t (Wstat: 2304 Tests: 1 Failed: 1)
Failed test: 1
Non-zero exit status: 9
Parse errors: Bad plan. You planned 42 tests but ran 1.
t/Pool02.t (Wstat: 2304 Tests: 1 Failed: 1)
Failed test: 1
Non-zero exit status: 9
Parse errors: Bad plan. You planned 337 tests but ran 1.
t/Pool03.t (Wstat: 65280 Tests: 1 Failed: 1)
Failed test: 1
Non-zero exit status: 255
Parse errors: Bad plan. You planned 339 tests but ran 1.
t/Pool04.t (Wstat: 65280 Tests: 1 Failed: 1)
Failed test: 1
Non-zero exit status: 255
Parse errors: Bad plan. You planned 170 tests but ran 1.
t/Pool05.t (Wstat: 2304 Tests: 1 Failed: 1)
Failed test: 1
Non-zero exit status: 9
Parse errors: Bad plan. You planned 37 tests but ran 1.
t/Pool06.t (Wstat: 2304 Tests: 1 Failed: 1)
Failed test: 1
Non-zero exit status: 9
Parse errors: Bad plan. You planned 21 tests but ran 1.
Files=6, Tests=6, 2 wallclock secs ( 0.03 usr 0.03 sys + 0.84 cusr 0.09 csys = 0.99 CPU)
Result: FAIL
Failed 6/6 test programs. 6/6 subtests failed.
make: *** [test_dynamic] Error 9
ELIZABETH/Thread-Pool-0.33.tar.gz
make test -- NOT OK
//hint// to see the cpan-testers results for installing this module, try:
reports ELIZABETH/Thread-Pool-0.33.tar.gz
Running make install
make test had returned bad status, won't install without force


2. using CPAN Command Prompt.

same as above.

3. downloading the Module from CPAN & installing with as below.

perl Makefile.pl

Warning: prerequisite Thread::Conveyor 0.15 not found.
Warning: prerequisite Thread::Conveyor::Monitored 0.11 not found.
Writing Makefile for Module::Load
Writing Makefile for Module::Load
Writing Makefile for Thread::Serialize
Writing Makefile for Thread::Tie
Writing Makefile for Thread::Conveyor
Writing Makefile for Thread::Pool


i have tried above dependency but not able to install same how one or the other gives me error.

could you please help me to install......

 

phranque

WebmasterWorld Administrator phranque us a WebmasterWorld Top Contributor of All Time 10+ Year Member Top Contributors Of The Month



 
Msg#: 4327955 posted 7:18 am on Jun 20, 2011 (gmt 0)

welcome to WebmasterWorld, manglesh!

have you tried installing the prerequisites separately yourself?

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / Perl Server Side CGI Scripting
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved