homepage Welcome to WebmasterWorld Guest from 54.205.254.108
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member
Home / Forums Index / Code, Content, and Presentation / Perl Server Side CGI Scripting
Forum Library, Charter, Moderators: coopster & jatar k & phranque

Perl Server Side CGI Scripting Forum

    
Search script outputting text
help a noob
bx1018




msg:3788904
 3:57 pm on Nov 18, 2008 (gmt 0)

We currently had our webmaster leave us at work and so now I'm picking up the pieces. We've had a migration project in place for a few weeks and when I migrate a certain site, the perl script that searches google actually prints the URL rather than redireting to it. If I move it back to the old server, it searches without issue.

The mail scripts (perl as well) work without any issues. The site is using the old searchem.pl script if you're familiar with that.

Please just let me know what additional information you might need. I apologize for my ignorance, as my forte is server side maintenance, not programming.

 

phranque




msg:3789182
 10:07 pm on Nov 18, 2008 (gmt 0)

welcome to WebmasterWorld [webmasterworld.com], bx1018!

check your HTTP Response document for HTTP headers.
the redirection url should be in a Location: header.
perhaps the script or server is returning headers for a HTML document response before the Location header is written.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / Perl Server Side CGI Scripting
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved