homepage Welcome to WebmasterWorld Guest from 54.161.175.231
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Pubcon Platinum Sponsor 2014
Home / Forums Index / Code, Content, and Presentation / HTML
Forum Library, Charter, Moderators: incrediBILL

HTML Forum

    
IE wont show iframe contents
... but will happily show the page on its own
londrum




msg:4118821
 3:00 pm on Apr 20, 2010 (gmt 0)

got a head-scratching problem that is winding me up big time.

i have an iframe on my site which shows ads. the page that appears inside the iframe is hosted on the same site, as are all of the images and stylesheets inside it. the code is just a simple piece of HTML. but IE refuses to show the contents. it's just blank.

when i visit the page itself, and view it on its own without the iframe, then IE will happily show the contents. its only when i try to view the page through an iframe that it wont.

every other browser i've tried -- firefox, opera, safari etc -- works fine.

p.s. i've also got some other iframes on my site, which contain maps, and they work perfectly okay. IE plays nice with those. so i know it cant be anything to do with IE's user settings.

if anyone has got a clue where i should be looking to fix it, that would be great

 

tedster




msg:4118970
 6:04 pm on Apr 20, 2010 (gmt 0)

Have you validated the page that should show inside the iframe?>

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / HTML
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved