homepage Welcome to WebmasterWorld Guest from 54.204.215.209
register, free tools, login, search, subscribe, help, library, announcements, recent posts, open posts,
Pubcon Website
Home / Forums Index / Google / Google SEO News and Discussion
Forum Library, Charter, Moderators: Robert Charlton & aakk9999 & brotherhood of lan & goodroi

Google SEO News and Discussion Forum

    
No Backlinks to Home in my WMT - just to internal pages
Mrkay




msg:3946861
 10:53 am on Jul 6, 2009 (gmt 0)

I have mentioned this in a thread on this forum and have seen it posted by others on other forums.

Basically WMT is showing no links to my my homepage, only deeper ones. I had approximately 1200 inbound links in total, including high quality ones from a national newspaper, blogs, high ranking directories and genuine ones from forums. Now WMT is showing I have 28 inbounds to sub-pages and my SERP has gone down about 12 places.

Any ideas anyone?

Thanks in advance.

 

tedster




msg:3947069
 5:53 pm on Jul 6, 2009 (gmt 0)

WMT is just a reporting utility, and it certainly does develop bugs - bugs that are not reflected in your actual rankings. Unless your ranking and traffic has dropped, this sounds like one of those bugs.

I wonder if others are seeing backlinks to their Home Page go missing. It's very possible that this data is stored separately from internal backlinks and has not been exported properly for WMT.

Mrkay




msg:3947500
 8:21 am on Jul 7, 2009 (gmt 0)

WMT is just a reporting utility, and it certainly does develop bugs - bugs that are not reflected in your actual rankings. Unless your ranking and traffic has dropped, this sounds like one of those bugs.

I wonder if others are seeing backlinks to their Home Page go missing. It's very possible that this data is stored separately from internal backlinks and has not been exported properly for WMT.

Tedster, my SERP has dropped recently to its lowest position in about a year, soon after being in its highest position ever. In the meantime my PR has gone up from 2 to 3. I did do quite a bit of submissions to directories and I'm a bit worried I over did it on my main keyword.

In Bing and Yahoo I'm 3rd and 4th respectively on the said keyword.

gouri




msg:3950739
 8:07 pm on Jul 11, 2009 (gmt 0)

I wonder if others are seeing backlinks to their Home Page go missing. It's very possible that this data is stored separately from internal backlinks and has not been exported properly for WMT.

I am also seeing some backlinks to inner pages but no backlinks to the homepage.

Mrkay




msg:3958929
 2:31 pm on Jul 24, 2009 (gmt 0)

Just to update this thread...........

Since I made the original post WMT is now miraculously showing 694 inbound links to my homepage. Also my SERP has improved by 20 places.

Why would Google lose all those inbound links?

UK_Web_Guy




msg:3959147
 6:43 pm on Jul 24, 2009 (gmt 0)

I noticed yesterday that WMT wasn't showing any links to my homepage, just inner pages.

I'm not overly concerned as this is just a webmaster tool at the end of the day - anyone else notice homepage links missing in WMT

I read on the webmaster blog that they updated WMT a few days ago, maybe that had something to do with it.

aristotle




msg:3959220
 9:27 pm on Jul 24, 2009 (gmt 0)

Even when WMT isn't broken, it still only shows a "sample" of the links to your site, and that sample isn't chosen logically. Individual pages are sometimes omitted from the lists even when they have more incoming links than other pages that are included. It's even possible that the omitted pages are determined randomly, so that occasionally even the home page will be left out.

tedster




msg:3959315
 1:26 am on Jul 25, 2009 (gmt 0)

Why would Google lose all those inbound links?

Google as a whole didn't lose them - just WebmasterTools, who has their own infrastructure. They seem to struggle with buggy reports every time the main Google backend goes through an "upgrade".

Hissingsid




msg:3959449
 9:42 am on Jul 25, 2009 (gmt 0)

I have this same issue. Interestingly it coincided with a small drop in ranking for my home page for some terms where we have been #1 for most of the last 8+ years. These are now back but Webmaster tools is still broken.

Cheers

Sid

Mrkay




msg:3960171
 9:50 am on Jul 27, 2009 (gmt 0)

<i>Google as a whole didn't lose them - just WebmasterTools, who has their own infrastructure.</i>

With respect I'm not sure that is true. The loss of links (as shown by WMT) coincided with with my drop in SERP and my recent rise in SERP has coincided with the reappearance of those inbound links.

tedster




msg:3960434
 5:46 pm on Jul 27, 2009 (gmt 0)

That is suggestive. And sometimes the process of a major new data push (update) does get buggy.

The "Site Reconsideration" in WMT is the best way to request a live person at Google take a look at the situation.

Mrkay




msg:3960847
 8:20 am on Jul 28, 2009 (gmt 0)

That is suggestive. And sometimes the process of a major new data push (update) does get buggy.

The "Site Reconsideration" in WMT is the best way to request a live person at Google take a look at the situation.

Even for a drop in SERP? I thought that was or more serious things lie being dropped from Google's index.

tedster




msg:3960885
 8:55 am on Jul 28, 2009 (gmt 0)

They renamed it from "Reinclusion Request" (which was originally for being dropped) to the current "Site reconsideration". It's your pipeline to have a person at least read what you have to say.

I certainly wouldn't use it for any old small drop in ranking. But I have successfully used it for a drop of many pages. I first did good research on the situation, then I plead my case.

I'd suggest watching Google's Help video first:
Tips on Requesting Reconsideration [youtube.com]

Mrkay




msg:3960904
 9:26 am on Jul 28, 2009 (gmt 0)

Thanks Tedster, that's very interesting.

Btw My SERP has fallen again (nowhere near its lowest position) about a page drop. I did some work on the site last week and overlooked moving a couple of pages, which caused some broken links which were found by WMT. Could that be a reason for the sudden fall?

Mrkay




msg:3962478
 1:36 pm on Jul 30, 2009 (gmt 0)

Further update.......

WMT is still showing 700 (ish) links to my homepage but has "lost" or is not showing any links to my second most important page - which has about 36 inbound links that I know of. Again my SERP has suffered.

briguy182182




msg:3962649
 5:59 pm on Jul 30, 2009 (gmt 0)

I saw the same thing a few months ago... homepage links disappeared for a while and then came back. My problem now is that the number of links WMT is showing me is stuck. It's been the same pretty much since my homepage links started appearing again. I know I've gotten new links in the past few months and know that Google has crawled the pages that they're on. Just curious if anyone knows how often they update that number and what percentage of your total backlinks you normally see.

UK_Web_Guy




msg:3962675
 6:40 pm on Jul 30, 2009 (gmt 0)

Mrkay

Did you do anything to get your homepage links showing again, like contact google or did they just reappear?

briguy182182

Did your loss of homepage links in WMT result in a drop in ranking,

briguy182182




msg:3962799
 10:35 pm on Jul 30, 2009 (gmt 0)

Web Guy,

My links just reappeared one day. The other interesting thing was there was no change in them... as if Google just forgot to report them rather than they lost them and had to recalculate them (which is why I just chalked it up to a bug).

I didn't notice any change in the SERPS or traffic while this was happening. It sounds like MrKay's dropped due to some broken links/new data push and it just happened to be when WMT wasn't displaying the homepage links. It sounds like he has quite a bit more backlinks than I do and I'm guessing does a better job of ranking/tracking SERP positions, so it might have had to do with internal Google data that the algo and WMT both use..... but as always it could have been something completely unrelated.

CainIV




msg:3962945
 5:01 am on Jul 31, 2009 (gmt 0)

Of late, especially during this update, there have been minor glitches and bugs with the GWT data, so I wouldnt place too much emphasis on that. It is unlikely that the ranking drop had anything to do with the link report in WMT.

I notice that at least once a day there is a tool or module in GWT that is not reporting data correctly.

ChicagoFan67




msg:3963690
 1:06 pm on Aug 1, 2009 (gmt 0)

I've seen this happen enough times to suggest that it is no coincidence. Two pages on my site are involved. The pages were held back in the SERPs and were omitted from the external links in WMT. When the pages were finally freed from whatever penalty, the links would show again in WMT. In both instances I have placed my own backlinks (only 1 for each) on a social networking site - something I rarely do. I've also changed the title once on each.

Just last week one of the pages went back under the penalty dropping from 2nd position to bottom of page 4 (or 14 depending on region). The number of backlinks for this page has grown very rapidly with webmasters (particularly in blogs) using the page title in anchor which is the targeted key phrase. I can understand that it might look a little suspicious to Google. However, the page is an alphabetical listing of everything on my site and a very useful page for people to link to. On Wednesday it was showing about 1200 links. I had a look for the page in GWT yesterday and sure enough, it is gone again!

Hissingsid




msg:3965904
 6:24 am on Aug 5, 2009 (gmt 0)

My WMT is as of now back to showing links to / . I'll let you know if it has any affect on SERPS.

Cheers

Sid

UK_Web_Guy




msg:3966475
 10:04 pm on Aug 5, 2009 (gmt 0)

back for me as well. don't think will see any change in ranking, think this was purely a WMT glitch.

halcyonlost




msg:3967631
 10:47 am on Aug 7, 2009 (gmt 0)

Mine finally updated as well. My only problem now is that I have only 1/10th of my links showing in the external links tool that I had before the big change.

The good news is that my ranks on KWs hasn't changed, anybody got the same problem?

ChicagoFan67




msg:3968238
 1:56 am on Aug 8, 2009 (gmt 0)

3 days ago I noticed my page had returned in WMT but with only 2/3rd's of the links showing. Today my page has had it's original ranking restored. mini sitelinks have also reappeared - I lost these as well during the big change.

Hissingsid




msg:3968338
 7:25 am on Aug 8, 2009 (gmt 0)

I should have said only about 2/3rds came back.

For my main target term on .co.uk I've gone back to #2 but no change on other terms and still worse on .com than .co.uk

I think the WMT issue is just coincidental to ranking issue but may be wrong.

Cheers

Sid

Hissingsid




msg:3968853
 6:13 pm on Aug 9, 2009 (gmt 0)

Hi,

Just looking closely at what I now have and they include no-follow links from competitor Alexa siteinfo pages where my site is listed under the related links tab.

Cheers

Sid

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Google / Google SEO News and Discussion
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About
© Webmaster World 1996-2014 all rights reserved