homepage Welcome to WebmasterWorld Guest from 54.205.247.203
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Pubcon Platinum Sponsor 2014
Home / Forums Index / Code, Content, and Presentation / JavaScript and AJAX
Forum Library, Charter, Moderator: open

JavaScript and AJAX Forum

    
is this a bug in netscape 7-re javascript
scorpion




msg:1493213
 12:59 am on Mar 21, 2003 (gmt 0)

When I use netscape 7.0 only, if I have rollover type code loading, the status bar always reads: transferring data from www.mysite.com...
and never ends transferring...is this a symptom of the rollover code? For example, in ie 6, shows the page completely loaded...

 

korkus2000




msg:1493214
 1:04 am on Mar 21, 2003 (gmt 0)

Sounds like there is something still running in the script. What script are you using for your rollovers?

scorpion




msg:1493215
 1:54 am on Mar 21, 2003 (gmt 0)

<!--
function MM_preloadImages() { //v3.0
}

function MM_findObj(n, d) { //v3.0
}

function MM_nbGroup(event, grpName) { //v3.0
}
//-->

from dreamweaver I think

it's called by:
onclick="MM_nbGroup('down','group1','yes','/images/yesoff.jpg',1)"
onmouseover="MM_nbGroup('over','yes',/images/yeson.jpg','',1)"
onmouseout="MM_nbGroup('out')"

in the a href of the button link...

jdMorgan




msg:1493216
 2:01 am on Mar 21, 2003 (gmt 0)

missing a closing single quote in this line?

onmouseover="MM_nbGroup('over','yes',/images/yeson.jpg','',1)"

Jim

scorpion




msg:1493217
 2:05 am on Mar 21, 2003 (gmt 0)

yeah, no that's not it..

This line causes this perpetual loading:

<body onLoad="MM_preloadImages('graphics/warning/b1-hi.gif','graphics/warning/b2-hi.gif')">

if the 'onLoad' line is removed, the page loads in netscape 7.0 and says "Document: (0.1s)"

When I put it back in, the browser keeps "transferring" like in a loop...

Anybody experience this?

korkus2000




msg:1493218
 2:15 am on Mar 21, 2003 (gmt 0)

Is there anything more than this in the preloader script?

function MM_preloadImages() { //v3.0
}

Your also missing a single quote here

onmouseover="MM_nbGroup('over','yes','/images/yeson.jpg','',1)"

scorpion




msg:1493219
 2:39 am on Mar 21, 2003 (gmt 0)

It's kind of weird, this is autogenerated dreamweaver code so it shouldn't have any bugs...

function MM_preloadImages() { //v3.0
var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
}

g1smd




msg:1493220
 10:55 pm on Mar 21, 2003 (gmt 0)

>> this is autogenerated dreamweaver code so it shouldn't have any bugs <<

I can't believe you just said that. Why should AGC be any less buggy?

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / JavaScript and AJAX
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved