homepage Welcome to WebmasterWorld Guest from 54.227.215.140
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member
Home / Forums Index / Google / Google AdSense
Forum Library, Charter, Moderators: incrediBILL & jatar k & martinibuster

Google AdSense Forum

    
Not seeing AdSense in FireFox
AdSense OK in IE6, not in Firefox
btas2

10+ Year Member



 
Msg#: 12154 posted 6:01 pm on Feb 16, 2006 (gmt 0)

I just noticed today that my AdSense ads aren't displaying in FireFox, but they are fine in IE6 and Opera. There's not even an empty block, they just aren't there - and my alternate ads aren't showing.

Nobody else's Adsense ads are displaying on other sites either

They used to be OK in IE6, FireFox and Opera and I have not (as far as I know...) installed any ad blocking plugins for Firefox.

I think (maybe) Firefox did an automatic update recently. Currenly it's version 1.5.0.1

Has anyone else seen this? It's a bit disconcerting that AdSense ads have sudddenly vanished without me having to take any steps to deliberately block them.

If other people are viewing my site via the same browser and have similarly "lost" MY Adsense ads, it's not exactly good for my business!

I'm aware that there are Ad blocking measures that can be added to FireFox - it's just that as far as I know, I didn't add any. Whether some other piece of software on my system did it for me, or whether an automatic Firefox update did it, I don't know yet.

Other Javascript on the pages is just fine, so I haven't accidentally turned Javascript off. Other Ads from other affiliates (Amazon) are also displaying fine and they use Javascript too. It's just AdSense as far as I can tell.

Whatever did it, now I have to find it and get rid of it since I'd like to see which ads AdSense is serving on my site!

BTW the Javascript console in Firefox is displaying a number of (non-fatal) errors related to both my own Javascript and Javascript from other affiliates like Amazon. However there is no mention at all of any AdSense Javascript, which either means it's perfect or it's simply not ever seeing it. Since I'm not seeing it either, I assume it's the latter.

[edited by: btas2 at 6:10 pm (utc) on Feb. 16, 2006]

 

sven1977

5+ Year Member



 
Msg#: 12154 posted 6:07 pm on Feb 16, 2006 (gmt 0)

Hi, I have the same version of Firefox as you have. But everything is fine with my ads. They are showing, IE or Mozilla, no difference. Sounds strange though. Sorry, but I can't help you, except for letting you know that it's not the version.

ypsites

10+ Year Member



 
Msg#: 12154 posted 6:10 pm on Feb 16, 2006 (gmt 0)

Do you have any javascript on the site by any chance? We had a similar problem, and it had to do with the javascript on our site. (In our case, we had no ads in Firefox, and improperly targeted ads in IE.)

If you do have javascript, try looking at any names you've included in the code for the conflict. In our case, we had something called "location" that conflicted with the adsense code. (Google changed adsense so we started having these problems after a couple years of everything working fine.) Once we switched to a different word in our js, all was well again.

sun818

WebmasterWorld Senior Member 10+ Year Member



 
Msg#: 12154 posted 6:20 pm on Feb 16, 2006 (gmt 0)

Do you have AdBlock installed on FireFox?

btas2

10+ Year Member



 
Msg#: 12154 posted 6:23 pm on Feb 16, 2006 (gmt 0)

Well I'm glad it's not just the browser! At least other people are probably seeing the ads.

I tried a reinstallation of Firefox, but it doesn't allow you to chose to install in a new directory, so it just updates the existing files. That made no difference, but if it didn't rewrite configuration files, I guess it wouldn't.

I have not ever installed Adblocking software on my system as far as I know. I have the google toolbar in IE6 to prevent popups, but nothing in Firefox. I'm running AntiSpyware and AntiVirus stuff (Microsoft and AVG), but they've been on the system for years. They do update, but I'd be very surprised if either of them messed with AdSense support.

My IE ads are still perfectly targeted, same as ever.

I'm suspecting that maybe some other program I have messed with Firefox. I've heard of Adware being installed via viruses, I've never heard of Anti-Adware being secretly put on anyone's system! Maybe it's a Yahoo plot?

AdSenseAdvisor

WebmasterWorld Senior Member 10+ Year Member



 
Msg#: 12154 posted 10:04 pm on Feb 16, 2006 (gmt 0)

Hey btas2!

Try the following:

1. Make sure cookies and SSL 2.0 are enabled on Firefox
2. Make sure JavaScript is enabled on Firefox
3. Clear your browser cache
4. Clear your browser cookies

If you follow these steps and still can't see ads, feel free to send me a sticky mail and we can investigate more.

-ASA

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Google / Google AdSense
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved