homepage Welcome to WebmasterWorld Guest from 54.198.140.148
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Pubcon Platinum Sponsor 2014
Visit PubCon.com
Home / Forums Index / Code, Content, and Presentation / PHP Server Side Scripting
Forum Library, Charter, Moderators: coopster & jatar k

PHP Server Side Scripting Forum

    
Same database on different server
Different output - odd symbols
humpo




msg:1265771
 3:42 pm on Oct 28, 2005 (gmt 0)

Character encoding

Have uploaded the same database to two different hosts.
Created a simple function to retrieve and output the content in html

On server A the content looks fine, but on server B the content has odd character symbols instead of apostrophes.
Both machines are using linux, MYSQL, and php

Tied few things and still non the wiser, have included any info i think might help.

On server A, using phpMyAdmin i can see ‘content’ field has the collation of latin1_swedish_ci
On server B, i can’t see what the collation is but know the default for the server is latin1

Server A
PHP 4.4.0
PHP CFG same excpet '--with-mysqli' '--with-imap' '--with-imap-ssl' '--with-kerberos'
MYSQL 4.1.13

Server B
PHP 4.3.11
PHP CFG same except '--with-gettext'
MYSQL 4.0.23

thanks

 

jatar_k




msg:1265772
 3:31 pm on Oct 31, 2005 (gmt 0)

sounds like different charsets maybe try

CHARSET [dev.mysql.com]

that might tell you what each is set to

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / PHP Server Side Scripting
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved