homepage Welcome to WebmasterWorld Guest from 54.204.94.228
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member
Visit PubCon.com
Home / Forums Index / Google / Google AdWords
Forum Library, Charter, Moderators: buckworks & eWhisper & skibum

Google AdWords Forum

    
Campaign Active but No Ads showing
no impressions, no ads showing
yonnermark




msg:1157717
 11:34 pm on Feb 20, 2006 (gmt 0)

Last night I started a new adwords account. I registered my card with it successfully and created about 5 ad groups containing broad, phrase and exact matches for a particular topic which is very popular. Lots of daily searches, lots of other advertisers etc.

But I got no impressions for the past 24 hours and my ad is nowhere to be seen when I search for my keywords.

Doesn't "active" mean that they ads will show?
My daily budget is plenty high enough
My maximum bid is also quite high.

Any ideas?
The only thing that may be relevent is that I redeemed a voucher for 30 of free clicks. I don't think that is anything to do with it but I thought I'd mention it for the sake of it.

Thanks for any tips
Mark

 

ronmcd




msg:1157718
 1:08 am on Feb 21, 2006 (gmt 0)

As its a new account and campaign you can be fairly sure theres nothing wrong, its just google manually approving your ads, I believe they now do this for all new accounts and for the first few campaigns. Might take a few days before your ads are looked at, suddenly you will start getting impressions and clicks. I wouldnt be tempted to increase your budget too much thinking thats the problem, you dont want to get a nasty shock when they suddenly switch it on :-)

yonnermark




msg:1157719
 10:11 am on Feb 21, 2006 (gmt 0)

Thanks for that advice.
My friend and I both opened new accounts on the same day and made our ads live in the same evening. His showed up instantly, mine are still not showing almost 48 hours later despite the status being "live".

hmmmm.

yonnermark




msg:1157720
 8:43 pm on Feb 21, 2006 (gmt 0)

*bump

48hrs and still no ads showing :(

risto




msg:1157721
 10:26 pm on Feb 21, 2006 (gmt 0)

If you have selected Content network, the editors must pre-check your campaign before putting you online.

yonnermark




msg:1157722
 10:30 am on Feb 22, 2006 (gmt 0)

ah cool.
I actually contacted live support/chat support at adwords and the lady I spoke to said she'd fastrack it for me. Withing 10 minutes my ads were live.

how good are google?

hotice_2002




msg:1157723
 1:21 pm on Feb 22, 2006 (gmt 0)

Hi, yonnermark

I must say you are lucky!

One of my new account created 10 days ago. And I send 5 emails and one telephone call to Google, the keywords are not showing by now! One representation told me the account is still under review, and she does NOT know how long will this review take!

I am very disappointed at this! Never seen a company like Google, the response time is very very long!

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Google / Google AdWords
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved