homepage Welcome to WebmasterWorld Guest from 54.196.206.80
register, free tools, login, search, subscribe, help, library, announcements, recent posts, open posts,
Subscribe and Support WebmasterWorld
Visit PubCon.com
Home / Forums Index / Google / Google AdWords
Forum Library, Charter, Moderators: buckworks & eWhisper & skibum

Google AdWords Forum

    
Found Correct keywords but?
removing productive keywords stops clicks
tank2006




msg:1142511
 5:20 pm on Feb 12, 2006 (gmt 0)

Hello All,

I have been using Adwords for sometime and finally narrowed things down to one set of keywords that work after tracking i.e. [blue widgets]. Here is the problem when I break that one set of keywords out in its own campaign (removing it out of an 800 keyword campaign) it dies. It seems to be in the same position but it wont pull any clicks like it does in the 800 keyword campaign. I am stumped by this, does Adwords do something when keywords are broke out individually in there own campaign with the same max bid and daily budget? I searched this forum and could not find a similar question please help Adwords Pros

Thanks in Advance.

 

Roe352




msg:1142512
 6:01 pm on Feb 12, 2006 (gmt 0)

They are probably putting your account in "review queue" everytime you make these changes to your keywords. That's my quess.

I've been having the same problem lately. Anything I do, puts my keywords into review and these reviews take up to 2 weeks. So, if you have to make frequent changes there is absolutely no way to beat the delay they have. At least this is my experience.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Google / Google AdWords
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About
© Webmaster World 1996-2014 all rights reserved