homepage Welcome to WebmasterWorld Guest from 54.197.183.230
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Pubcon Platinum Sponsor 2014
Home / Forums Index / WebmasterWorld / New To Web Development
Forum Library, Charter, Moderators: brotherhood of lan & mack

New To Web Development Forum

    
a href problem
infernofiasco

10+ Year Member



 
Msg#: 832 posted 12:42 pm on Sep 24, 2003 (gmt 0)

Iam trying to link a record from database and making it into a link:

<a href="<%=(rs_images.Fields.Item("filename"))%>"><%=(rs_images.Fields.Item("filename").Value)%></a>

when i run the page the file name wont come up?

why is that and how do i create a proper link.

 

BlobFisk

WebmasterWorld Senior Member blobfisk us a WebmasterWorld Top Contributor of All Time 10+ Year Member



 
Msg#: 832 posted 12:46 pm on Sep 24, 2003 (gmt 0)

Does the database record have the file extension (eg .html)?

If not you will need to add that....

infernofiasco

10+ Year Member



 
Msg#: 832 posted 12:48 pm on Sep 24, 2003 (gmt 0)

No its actually a file.

Like
file name
text.txt (link)
new document.doc (link)

davegerard

10+ Year Member



 
Msg#: 832 posted 5:38 am on Sep 25, 2003 (gmt 0)

If you can capture the filename with the FileSystemObject you can create a variable for the name and perhaps use that in your link.

MyFile = File.Name
<a href="<%=MyFile%>">MyFile</a>

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / WebmasterWorld / New To Web Development
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved