homepage Welcome to WebmasterWorld Guest from 54.211.97.242
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Microsoft / Microsoft IIS Web Server and ASP.NET
Forum Library, Charter, Moderators: ocean10000

Microsoft IIS Web Server and ASP.NET Forum

    
ASP and Access
True/False db field causes 500 error
chris_f

WebmasterWorld Senior Member 10+ Year Member



 
Msg#: 1901 posted 8:01 am on Jun 16, 2004 (gmt 0)

Hi All,

This has been annoying me for two days and I'm hoping someone can call me a dip and point out something obvious that is wrong. I am using ASP to update a TRUE/FALSE field in an access database.

Whenever the update is perfomed I get:

Microsoft JET Database Engine error '80040e10'
No value given for one or more required parameters.
/forum/ocbs/ocbs2/manager/manbookings.asp, line 153

The line of code is:

CancelBooking.Open "UPDATE Bookings SET CancelledBooking = 'TRUE' WHERE BookingID = " & Request.Form("bookingid")

If I update another field it works fine and I have verified the field name "CancelledBooking". It must be the TRUE bit, however, I have tried it as TRUE, 'TRUE' and "TRUE" to no avail.

Thanks
Chris

 

chris_f

WebmasterWorld Senior Member 10+ Year Member



 
Msg#: 1901 posted 8:16 am on Jun 16, 2004 (gmt 0)

Please ignore. Fized.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Microsoft / Microsoft IIS Web Server and ASP.NET
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved