homepage Welcome to WebmasterWorld Guest from 54.204.127.56
register, free tools, login, search, subscribe, help, library, announcements, recent posts, open posts,
Subscribe to WebmasterWorld
Home / Forums Index / Hardware and OS Related Technologies / Linux, Unix, and *nix like Operating Systems
Forum Library, Charter, Moderators: bakedjake

Linux, Unix, and *nix like Operating Systems Forum

    
Linux Suse 8.1 upgrade problems
I'm a dummie
hermanjohan




msg:912928
 8:52 am on Feb 18, 2003 (gmt 0)

When I want to upgrade my Opera 6.3 that is included in the Linux Suse 8.1 pack, I get problems.
I have to install the download with Yast2, as Kpackage does not exist anymore in the latest 8.1 version of Suse Linux.
The problem is, that with installing the upgrade 6.11 in Yast2, Yast2 asks for the installation DVD. When I then click "Install" in the Yast2, it does not install 6.11 but reinstalls the Opera 6.3 that is on the DVD.

Another possibility is to install with xterm, but that does not reckognise the downloded file...! So calling to Suse support, they advised me to download the static version and then install with xterm again. But for me xterm is pretty difficult.

Does anyone know how to get in an easy way the newest version in my Linux Suse 8.1 system?

Thanks...!
herman

 

NGene




msg:912929
 5:45 pm on Feb 18, 2003 (gmt 0)

If you haven't already downloaded the appropriate Opera package, go to their website and download the Qt static RPM package for Opera 6.11.

After downloading, open up xterm. Make sure you're doing it as root. If you're not root when opening up the xterm, type su and then your root password in xterm.

After doing it, install the Opera package by typing this in xterm:

rpm -U packagename.rpm

where, of course, packagename.rpm is the name of the Opera package you just downloaded.

NGene




msg:912930
 6:18 pm on Feb 18, 2003 (gmt 0)

By the way, check your Sticky mail.

hermanjohan




msg:912931
 10:56 pm on Feb 18, 2003 (gmt 0)

Dear NGene,

Thanks for your beautiful link and kind advise.

I dowloaded opera-6.11-20021129.1-static-qt.i386.rpm into my file:home/herman
Then I typed in your command. I saw a lot op things moving in xterm suddenly and the downloaded file in home/herman is disappeared. With the "find files" option, I cannot find the file anymore. I wished I could copy the screen of x term, to show you, but I don't know how to do that. Cannot find that in the manual either. Sorry...! I will leave my computer on for a while, so if I receive some hints how to copy the xterm file I will send it here.

I still have Opera 6.3 and cannot find 6.11 anywhere anymore :(

greetings,

herman

hermanjohan




msg:912932
 12:37 am on Feb 19, 2003 (gmt 0)

Found the file...! It's only just moved from Home/herman to Home/herman/documents.

That's the original place, where Opera itself wanted to put the downloded file. I did not want it in Documents, that's why I changed the download directory manually, downloading.

For the rest I cannot find any other 6.11 opera in "find file" *opera*n nor any zipped or installed 6.11 Operabrowserfile

greetings,

herman

NGene




msg:912933
 9:02 am on Feb 19, 2003 (gmt 0)

Hmm... interesting. Probably the messages in the xterm were some sort of errors. If you want to copy text from xterm, just highlight it with your mouse. To paste it (into your message here at webmasterworld for example) press the middle button of your mouse, or if you have a 2-button mouse, press both of the buttons simultaneously.

What happens if you simply try running Opera after installing the RPM package? It's still the same 6.3?

hermanjohan




msg:912934
 12:17 pm on Feb 19, 2003 (gmt 0)

Hi NGene,

Thanks for explaining how to copy a xterm file!

The operabrowser I'm using is unfortunately still the version 6.3. At no place in the "find files" system I can find that version 6.11 is installed somewhere.

The xterm files age gone now, but it seemed yesterday to me, that it did not show installing something at all.

Greetings,

herman

hermanjohan




msg:912935
 2:08 pm on Feb 19, 2003 (gmt 0)

Dear NGene,

I know the static Opera upgradefile is in /home/herman/Documents now. Down here you can see what xterm says back now, if I type in the way you suggest. Or do I make some stupid mistake...?
______________________________________________________________________________

herman@linux:~> sux -
Password:
linux:~ # rpm -U opera6.11-20021129.1-static-qt.i386.rpm
error: cannot open file opera6.11-20021129.1-static-qt.i386.rpm: No such file or directory
linux:~ #
______________________________________________________________________________

I am a dummie... I really don't know anymore how to get a more recent Operabrowser. Wished that the autoinstall in Yast2 worked better...!

kind regards,

herman

NGene




msg:912936
 7:02 pm on Feb 23, 2003 (gmt 0)

It seems like the shell can't find the RPM file. There may be two reasons.

1) Maybe you've simply made a typo when typing the file name?

Right here:
rpm -U opera6.11-20021129.1-static-qt.i386.rpm

When I upgraded my Opera browser, the file name was like this:
rpm -U opera-6.11-20021129.1-static-qt.i386.rpm

I know the file names can differ, so maybe this isn't the reason. However, you can avoid typos by using a feature called "file name completion." Just type the first letters of a file name, hit the Tab key and the file name is completed! For example, type only rpm -U opera , hit the Tab key and see what happens...

2) are you sure you're issuing the rpm -U file.rpm command in the same directory where the RPM file is? If you're not, either use the cd command for changing to the directory or specify the whole path to the file when issuing the command.

hermanjohan




msg:912937
 10:13 pm on Feb 23, 2003 (gmt 0)

Dear NGEne,

I came a little further, though it makes no difference wheather I try to install the "static" or the "shared Suse"-opera.rpm.

I found that very few other people are having the same problems installing a *.rpm in Suse 8.1.

I show you here my latest results with Xterm, but still can't find out how to get further the upgrade of the newest Operabrowser installed.
___________________________________________________
herman@linux:~> sux -
Password:
linux:~ # rpm -Uhv
/home/herman/Documents/opera-6.11-20021129.2-shared-qt.i386.rpm
error: failed dependencies:
libXm.so.2 is needed by opera-6.11-20021129.2
linux:~ #
____________________________________________________________

Kind regards,

herman

hermanjohan




msg:912938
 11:03 pm on Feb 23, 2003 (gmt 0)

Dear NGene,

Can I use "file name completion" also in xterm? Where can I find that program?

Kind regards,

herman

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Hardware and OS Related Technologies / Linux, Unix, and *nix like Operating Systems
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved