homepage Welcome to WebmasterWorld Guest from 107.20.25.215
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Hardware and OS Related Technologies / Linux, Unix, and *nix like Operating Systems
Forum Library, Charter, Moderators: bakedjake

Linux, Unix, and *nix like Operating Systems Forum

    
Help with X problems
After upgrade to RH8
Nick_W




msg:910991
 12:11 am on Nov 13, 2002 (gmt 0)

Hi all,

I managed my upgrade but had to re-download the nvidia drivers and compile/install.

Now I have X back, kind of. From my desktop this is what's happening:

Moz will load
Gimp will load
Opera won'
ICQ won't

I can get a console but the text is *huge* (significant?)

Can anyone give me any pointers on getting my system back on track?

Thanks....

Nick

 

littleman




msg:910992
 12:48 am on Nov 13, 2002 (gmt 0)

Might be a font path problem. Did you rerun the X configuration utility RH provides? It could be that your are running on the old XF86Config file. I don't use RH but I believe the Xconfig file will be sitting at /etc/X11/XF86Config-4.

Nick_W




msg:910993
 7:10 am on Nov 13, 2002 (gmt 0)

Just woke up. With the burning thought that maybe during install I mangaged not to install fonts. Or something.

It follows that maybe Moz uses it's own fonts and Opera, ICQ etc: system fonts. Also would explain why my console has a really unreadable font.

Off to re-upgrade. Carefully!

Thanks

Nick

Duckula




msg:910994
 7:17 am on Nov 13, 2002 (gmt 0)

If Opera doesn't load most probably the new system doesn't have a shared library that Opera used, most probably some QT.

Try doing

ldd `which opera`

and see if any line says "not found". That will find, if possible, the path to the shared libraries.

Two notes: those are backticks, not regular ticks; and replace if necessary opera for the binary name. I don't have one installed right now, and can't remember what name is it, and if is of a binary or an script.

Nick_W




msg:910995
 8:15 am on Nov 13, 2002 (gmt 0)

Hmmmm... no joy with opera but I tried it on licq and there where no errors or missing files.

The fonts appear to be the problem. Huge unreadable fonts on the k konsole and desktop and some aps won't start.

Here's what I get when I try to execute Opera from the console:

/usr/lib/opera/6.10-20021029.3/opera: relocation error: /usr/lib/opera/6.10-20021029.3/opera: undefined symbol: __ti10QTextCodec

Make any sense?

Cheers....

Nick

Duckula




msg:910996
 8:30 am on Nov 13, 2002 (gmt 0)

It does. It means what I did suspect: there's an incompatibility of QT versions.

QTextCodec is a QT class that converts between text encodings. The relocation error means that the binary was compiled against a version, but you do have another, then it can't find the exact symbol that was looking for.

Normally I'd say "recompile it"; but in this case the solution is either a) download a QT static Opera; b) download an Opera for your specific distro or c) (best one) install the compatible old QT, it must be somewhere on your install disk and probably will coexist with the new one.

Nick_W




msg:910997
 8:34 am on Nov 13, 2002 (gmt 0)

Thanks very much.

2 questions:

1. How does this relate to the 'huge unreadable fonts' I'm seeing on my desktop/console?
2. How might I recognize/install this file?

I'm using iso images and I can't work out how to mount it? I can't seem to work out what mount point to specify?

Cheers......again!

Nick

Duckula




msg:910998
 8:52 am on Nov 13, 2002 (gmt 0)

1. How does this relate to the 'huge unreadable fonts' I'm seeing on my desktop/console?
It doesn't. I'm assuming that you're using KDE and by console you mean konsole. To set fonts there use kcontrol or the control panel icon.

2. How might I recognize/install this file?

Most probably RH8 has newer libraries and doesn't install older by default. Do the ldd check that I mentioned before. Then, when you find out what library is missing (it should tell) use the redhat system update tool (I haven't used redhat in a time, there should be one) and install something that begins by libqt and matches the line that says "missing" on ldd.

how to mount it?

If simply 'mount /mnt/cdrom' or 'mount /cdrom' doesn't work, simply set the mount point to any empty directory (/mnt/cdrom or /cdrom will work :)) and use as command (as root)

mount -t iso9660 /dev/cdrom /mnt/cdrom

<added>
Since you published your opera path, the command will be

ldd /usr/lib/opera/6.10-20021029.3/opera

The `which` bit was to find out the full path of the binary.
</added

[edited by: Duckula at 9:00 am (utc) on Nov. 13, 2002]

Nick_W




msg:910999
 8:56 am on Nov 13, 2002 (gmt 0)

Right. I can do the first things. But my ISO images are on hard drive. The docs say:

mount -o loop iso9660 -t <filename> <mountpoint>

It's the mount point I have no idea of?

Nick

Duckula




msg:911000
 9:02 am on Nov 13, 2002 (gmt 0)

Mount point can be any empty directory. And your command is wrong; it should be

mount -o loop -t iso9660 <filename> <mountpoint>

Nick_W




msg:911001
 10:04 am on Nov 13, 2002 (gmt 0)

Hmmm... doens't look like anythings missing....

libpthread.so.0 => /lib/i686/libpthread.so.0 (0x40027000)
libdl.so.2 => /lib/libdl.so.2 (0x40058000)
libqt.so.3 => /usr/lib/qt-3.0.5/lib/libqt.so.3 (0x4005b000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40689000)
libm.so.6 => /lib/i686/libm.so.6 (0x40767000)
libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
libcups.so.2 => /usr/lib/libcups.so.2 (0x40789000)
libmng.so.1 => /usr/lib/libmng.so.1 (0x407a4000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x407e8000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0x40806000)
libz.so.1 => /usr/lib/libz.so.1 (0x40829000)
libGL.so.1 => /usr/lib/libGL.so.1 (0x40837000)
libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x4087f000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40896000)
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x408ad000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x408b6000)
libXrender.so.1 => /usr/X11R6/lib/libXrender.so.1 (0x408c4000)
libXft.so.2 => /usr/lib/libXft.so.2 (0x408c9000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x408db000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
libssl.so.2 => /lib/libssl.so.2 (0x40901000)
libcrypto.so.2 => /lib/libcrypto.so.2 (0x40931000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x40a05000)
libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x40d9f000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40df1000)
libexpat.so.0 => /usr/lib/libexpat.so.0 (0x40e3a000)

Nick

Duckula




msg:911002
 2:00 am on Nov 14, 2002 (gmt 0)

Then there's another posibility. Your system's QT libraries were compiled with a GCC version that produces c++ symbol incompatibility. You are then out of luck, since you can't recompile Opera. Go for the static version or download the exact version for your distro, that hopefully was compiled by the same compiler.

That is a problem with C++ libraries only, that's why it's not very common. Mozilla is linked against gtk, that is a C library, for example. The keyword here is "name mangling"; you probably don't want to know more.

Nick_W




msg:911003
 6:23 am on Nov 14, 2002 (gmt 0)

I don't think that's it. I've re-upgraded, selecting everything to install. About 4GB! and I now have a working Opera, and ICQ.

However, the font on my 'konsole' and Opera and pretty much anything else I do is dreadfull. Opera keeps crashing and I can barely read the console screen.

Somewhere I have a font problem. I just have no idea of where to start looking or what to change?

Thanks again...

Nick

Duckula




msg:911004
 6:48 am on Nov 14, 2002 (gmt 0)

Around QT apps I did have the same problem; but only when not using KDE as desktop manager, and I more often use a bare bones sawfish.

What I did do to solve it was to hack in /etc/X11/XF86Config-4 and substitute the 75dpi, 100dpi and misc paths for unscaled ones; the really ugly fonts went away, but the default one of QT was a little big.

I haven't found an 'easy' way to set QT default fonts as in .gtkrc, I really tried once.

But none of that happened when using KDE. Since I don't use it and I didn't use any QT app anyway, except sometimes aviplay but there the fonts didn't really mattered, I could live with that.

The lines I fixed at /etc/X11/XF86Config-4, if you want to try, were

(I don't use the font server, comment that line)
# FontPath "unix/:7100"

FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/misc/:unscaled"

The only difference is the trailing :unscaled; that will stop QT from scaling unscalable fonts. As a matter of fact, will stop *anything* of using a scaled font from these paths, so some X apps will take different default fonts than before.

But that shouldn't matter if you're using KDE; I can't guess more.

P.S. Disclaimer: The way that I used to modify the fonts should not be considered the 'correct' way by any means. Try before with the font management system that your system or KDE use. Consider yourself warned.

P. P. S. Adobe Helvetica fonts, that are the ones that QT likes to take by default, are really ugly on most systems. That should be your problem.

Son_House




msg:911005
 3:36 pm on Nov 21, 2002 (gmt 0)

Not sure if it will help but I read about another persons problems with fonts in RH 8 and they said basically that it only happens in KDE. Fonts work fine with Gnome they said.

They also talked about editing /etc/sysconfig/i18n and changing LANG to C

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Hardware and OS Related Technologies / Linux, Unix, and *nix like Operating Systems
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved