homepage Welcome to WebmasterWorld Guest from 54.205.168.88
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Hardware and OS Related Technologies / Linux, Unix, and *nix like Operating Systems
Forum Library, Charter, Moderators: bakedjake

Linux, Unix, and *nix like Operating Systems Forum

    
Slackware pros?
getting close
john316




msg:915813
 9:17 pm on Jul 5, 2002 (gmt 0)

I am doing (trying) an NFS install on a notebook, all systems are go until the final NFS mount...I keep getting a timeout (RPC timed out).

Is this an issue with the remote server?

Any help would be *greatly* appreciated.

 

Air




msg:915814
 9:49 pm on Jul 5, 2002 (gmt 0)

It's probably an issue with the speed of the connection, RPC's are very prone to timeouts on lower bandwidth lines (say less than 256kb, depending on what else is going on).

john316




msg:915815
 10:11 pm on Jul 5, 2002 (gmt 0)

Thanks Air, but I think I'm doing it wrong, it is asking for the address of the NFS server and then the directory...should I be telling it to get a specific file instead of connecting to a directory?

Air




msg:915816
 11:52 pm on Jul 5, 2002 (gmt 0)

The remote server must allow the mount to the mount point (you are correct it is to a directory not a file). Are you using a command line mount command from the laptop to set up the NFS mount on the server, or are you configuring the laptop's /etc/fstab file to do the mount at boot time and it fails?

john316




msg:915817
 12:47 am on Jul 6, 2002 (gmt 0)

I am using the slackware floppies. It asks for my IP,netmask,gateway, then it asks for the IP address of the NFS server and the directory on the server.

I hit "ok" and it configures the ethernet card, configures the gateway and then it says:

Mounting NFS...

then I get a message saying:

RPC timed out

You can tell I am a major newbie with this, I'm just doing what the disks say to do.

I am wondering if the server that I am connecting to (I have tried several) doesn't like my IP address...should I give it the resolved number?

Air




msg:915818
 2:59 am on Jul 6, 2002 (gmt 0)


Ah ok, you're doing a network install (notoriously troublesome), make sure that you can indeed get to the server by pinging it, there could be many reasons for the results you are seeing with NFS, have a gander at this page at [uwsg.iu.edu...] and see if it helps. Alternatively do what I am doing right now (well my puter is anyway) download your favourite distros from [linuxiso.org...] and burn them to CD.

>doesn't like my IP address...should I give it the resolved number?
If you mean give it the IP address instead of host name then yes.

john316




msg:915819
 4:28 am on Jul 6, 2002 (gmt 0)

Thanks Air

No CD available..so I guess I'll keep going down the NFS road.

From what I've read about the NFS stuff, the server and the client both have to configured correctly, it might just be a matter of "hunt and peck" to find the right server.

At least it's more fun than fiddling with Windows :)

bartek




msg:915820
 4:58 am on Jul 6, 2002 (gmt 0)

Like Air said, NFS installs can be a pain. You'll likely have much better luck installing through FTP. Is that an option for you?

john316




msg:915821
 11:54 am on Jul 6, 2002 (gmt 0)

Hi Bartek

The situation is a working laptop with a floppy drive, the cd is either broken or it is missing drivers (it is one of those swappable drives), I don't think I can diagnose the CD until I get an OS installed.

I put a nic card in and the install floppies got that to work. I have a blank hard drive waiting for an OS.

I was wondering if the router would prevent the NFS server from resolving the IP or if I am just requesting the wrong files.

Air




msg:915822
 4:40 pm on Jul 6, 2002 (gmt 0)

I don't know what server you are connecting to, but I just did an NFS mount to THIS ONE [zlilo.com] and it worked. See if that helps you, the example on the page conveniently is for the Slackware distro ...

littleman




msg:915823
 12:36 am on Jul 7, 2002 (gmt 0)

I cant help with your NFS problems but you may want to try the the Debian Woody floppy install. I've done it on two machines now and it seems to work well for the most part.

The way it works is that you copy a minimum install to 6 floppies and that is enough to get you connected to the internet. After that you install the rest via the web. I just did it again last night -- I replace Mandrake, apt-get made me a convert.

There is a tutorial here:
[zorka.com...]
And here:
[debian.org...]

But I would start with the floppies from the woody section instead of stable, it will start you off with a lot more current foundation.

Here are the Woody floppy images:
[ftp.us.debian.org...]

john316




msg:915824
 2:57 am on Jul 7, 2002 (gmt 0)

Thanks Air

I found out that I didn't have a mount point configured correctly at my end (a partitioning issue), so when I connected to that guys server it tried to mount my disk like a million times a minute (I shut it down when I started to smell router). My mistake..I didn't have a moint point. I hope his server is okay.

So, anyway I backed out of the slackware install, because I couldn't seem to get the disk partitioned correctly and got a copy of Red Hat which does the partition thing automatically. I let the installer do its thing and I am downloading it(RH)now (only 3 more hours to go).

I appreciate your assistance, I'm sure I'll give slackware another shot soon.
--
Thanks littleman, something tells me that getting out of Linux is a lot harder than getting into it and I'm sure I'll be giving some of the other flavors a run.

"You'll likely have much better luck installing through FTP"...yep..the router cooled down a bit :) Thanks Bartek

john316




msg:915825
 2:12 pm on Jul 8, 2002 (gmt 0)

Update:

This is my first post running Linux...I like it.

Thanks again

littleman




msg:915826
 5:17 pm on Jul 8, 2002 (gmt 0)

Congratulations! ...And nice work figuring out how to get it installed without a CDrom.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Hardware and OS Related Technologies / Linux, Unix, and *nix like Operating Systems
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved