homepage Welcome to WebmasterWorld Guest from 54.234.228.64
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Hardware and OS Related Technologies / Website Technology Issues
Forum Library, Charter, Moderators: phranque

Website Technology Issues Forum

    
Unusual Problem - HTTP vs. HTTPS
why does this happen...
irubin




msg:662768
 5:47 pm on Sep 17, 2003 (gmt 0)

Hello,

I am running a php script that provides a different output if viewed from HTTP and HTTPS - even though it is the same script.

When I analyze the HTML- in some cases the <table> tag is transformed into </able>. Somehow the page is parsed and items are stripped. Can this be Apache? the Certificate?

snip

Any comments will be appreciated.

[edited by: DaveAtIFG at 7:30 pm (utc) on Sep. 17, 2003]
[edit reason] URLs removed [/edit]

 

jatar_k




msg:662769
 7:09 pm on Sep 18, 2003 (gmt 0)

I run tons of the same scripts with http and https and it doesn't cause any problems like the one you have.

Any more info possibly? It sounds like the script itself is doing something strange.

irubin




msg:662770
 7:21 pm on Sep 18, 2003 (gmt 0)

the script is an oscommerce shopping cart and the problem seems the be in closing the sessions.

I removed the session_close references and it seemed to fix the problem.

Any idea why? I am clueless on how and why such a thing would happen.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Hardware and OS Related Technologies / Website Technology Issues
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved