homepage Welcome to WebmasterWorld Guest from 54.205.236.46
register, free tools, login, search, subscribe, help, library, announcements, recent posts, open posts,
Pubcon Website
Home / Forums Index / Code, Content, and Presentation / HTML
Forum Library, Charter, Moderators: incrediBILL

HTML Forum

    
New Favicon won't show up
old one still displays
microcars




msg:606606
 11:42 pm on May 15, 2006 (gmt 0)

I've changed the actual favicon.ico file on a site and no matter what browser I use, I can't get the new file to show.

The old one still shows in every browser

I have an absolute address in the header:
<link rel="shortcut icon" href="http://www.example.com/favicon.ico">

this has worked great in the past, but where does it get the "old" favicon from? I've tried clearing the caches on the browsers to no avail and I certainly can't go clearing the caches of everyone else's browsers.

This is kind of a problem because the site has changed owners and the new one does not want to be associated with the old one, this is the last piece.

 

4hero




msg:606607
 9:47 pm on May 16, 2006 (gmt 0)

Hi,

This happened to me recently :( I ended up changing the path to the favicon. Try moving it into your images folder or something?

<link rel="shortcut icon" href="http://www.example.com/images/favicon.ico">

Good luck!

Lobo




msg:606608
 10:52 pm on May 16, 2006 (gmt 0)

Have you tried shaking it? no seriously ..

I still don't know why it happens but if you click on th favicon shake it and release .. pop! there it appears ...

kaled




msg:606609
 11:35 pm on May 16, 2006 (gmt 0)

Enter the url of the icon in the address bar of your browser.

Kaled.

microcars




msg:606610
 4:14 am on May 17, 2006 (gmt 0)

hmm, if I enter the URL of the favicon, it shows up in the browser window as a 32x32 icon

I used an "auto favicon generator" website (won't say which one) and I guess it gave me a 16x16 and a 32x32 in one favicon.ico file

maybe that's the problem?

when I moved it to the Images folder and changed the shortcut link, it dumped the old icon.

microcars




msg:606611
 2:37 pm on May 17, 2006 (gmt 0)

well, now it works, quitting browsers and relaunching them after moving the favicon seems to have done the trick, but then when I moved the favicon.ico icon BACK to where it was....all the browsers start showing the OLD icon again!

arrrghhh

kaled




msg:606612
 4:07 pm on May 17, 2006 (gmt 0)

Like other documents, favicons are cached locally by browsers. Clear the cache and then enter the url of the icon and if necessary hit F5. That should sort out the problem.

Kaled.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / HTML
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About
© Webmaster World 1996-2014 all rights reserved