homepage Welcome to WebmasterWorld Guest from 54.205.122.62
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Browsers / Firefox Browser Usage and Support
Forum Library, Charter, Moderators: incrediBILL

Firefox Browser Usage and Support Forum

    
Firefox and iframes
site not coming up correcting in Firefox
RangerChic

5+ Year Member



 
Msg#: 231 posted 7:22 pm on Mar 9, 2005 (gmt 0)

My site comes up fine in IE, but not Firefox. If anyone can help me figure out why the code is going to the left in Firefox, I'd very much appreciate it! Thanks!

S!

<Sorry, no personal URLs.
See Terms of Service [webmasterworld.com]>

[edited by: tedster at 8:14 pm (utc) on Mar. 9, 2005]

 

cmatcme

5+ Year Member



 
Msg#: 231 posted 7:27 pm on Mar 9, 2005 (gmt 0)

Welcome To Webmasterworld.

The most common answer is that Firefox may not recognize the code.

However, a code sample may be helpful so we can identify the problem whether its used in javascript or not...

Thou shalt not post promotional urls

    It's in the sacred tos!;)

RangerChic

5+ Year Member



 
Msg#: 231 posted 8:08 pm on Mar 9, 2005 (gmt 0)

Oh, sorry! Here's the code:


<script language="javascript" src="http://www.example.com/cgi-bin/popup_mainsite.js"></script>
<script language="JavaScript" src="http://www.example.com/4/placement/1385/"></script>
<html>
<head>

<style> <!-- A:link {text-decoration: none} A:visited {text-decoration: none} A:active {text-decoration: none} A:hover {text-decoration: none; color: #1F539F}body { scrollbar-face-color: #FFFFFF; scrollbar-shadow-color: #000000; scrollbar-highlight-color: #1F539F; scrollbar-3dlight-color: #ffffff; scrollbar-darkshadow-color: #FFFFFF; scrollbar-track-color: #FFFFFF; scrollbar-arrow-color: #1F539F}--></style>

<title>Title Text</title>

</head>
<META NAME="keywords" CONTENT="keyword list">
<META NAME="description" CONTENT="description text">
<META NAME="author" CONTENT="author name">
<META NAME="robots" CONTENT="FOLLOW,INDEX">

<body bgcolor=#FFFFFF bottommargin=0 link="1F539F" alink="1F539F" vlink="1F539F" text="#1F539F">

<table align=left width=500 cellpadding=3 border=0>
<td width=150 valign=top>

<table border=0 cellpadding=1 bgcolor=#FFFFFF>
<tr>
<td valign=top height="10" width="175" style="border: 1 solid #000000">
<font color=#000000><center><b>Menu</b></font></center>
</td></tr><tr>
<td valign=top width="150" bgcolor=#FFFFFF style="border: 1 solid #000000">
<font size="2">
<a href="main.html" target="main">Home</a>
<BR>
<a href="http://www.example.com" target="blank">Blog Babblings</a>
<BR>
<a href="projects.html" target="main">Current Projects</a>
<BR>
<a href="appearances.html" target="main">Appearances</a>
<BR>
Art Gallery</a>
<BR>
<a href="photo.html" target="main">Photo Gallery</a>
<BR>
Buy Comics/Merchandise</a>
<BR>
<a href="contact.html" target="main">Contact Info</a>
<BR>
<a href="links.html" target="main">Links</a>
</font>
<br>
</td></tr></table>
<br>

<table border=0 cellpadding=2 bgcolor=#FFFFFF>
<tr>
<td valign=top height="10" width="150" style="border: 1 solid #000000">
<font color=#000000><center><b>Upcoming Projects</b></font></center>
</td></tr><tr>
<td valign=top width="150" bgcolor=#FFFFFF style="border: 1 solid #000000">
<font size="2">
<center><img src="lineissone.jpg">
<br><b>The Line #1</b></center>
<center><i>March 2005</i></center>
</font>
</td></tr></table>
<br>

<table border=0 cellpadding=2 bgcolor=#FFFFFF style="position:absolute; top: 10px; left:200px" width=500>
<tr>
<td valign=top width="500" height="250" border=0> <a href="main.html" target="main"><img src="http://rangerchic.com/linesitetop.jpg" border="1" alt="alt text" width=500 height=250 style="border: 1 solid #000000"></a>
</td>
</tr><tr>

<td valign=top width="500" bgcolor=#FFFFFF style="position:absolute; top: 255px; left: 4px; border: 0 solid #254A6F;">
<iframe height="300" width="500" src="main.html"
name="main" style="BORDER-left: 1 solid #254A6F; border-right: 1 solid #254A6F; border-bottom: 1 solid #254A6F; LEFT: 0px; BOTTOM: 0px; POSITION: absolute; TOP: 0px;
hspace: 0px" frameborder="0" scrolling="Auto">
<ilayer height="250" width="300" name="main"
src="main.html"></ilayer>
</iframe> </td>
</tr>
</table>
<br>
<br>
<br>
<br>
<br>

</html>

S!

[edited by: tedster at 8:18 pm (utc) on Mar. 9, 2005]
[edit reason] remove specifics [/edit]

RangerChic

5+ Year Member



 
Msg#: 231 posted 6:21 pm on Mar 10, 2005 (gmt 0)

Can anyone help? Thanks!

RC

2by4

WebmasterWorld Senior Member 10+ Year Member



 
Msg#: 231 posted 7:17 pm on Mar 10, 2005 (gmt 0)

<<< <iframe height="300" width="500" src="main.html"
name="main" style="BORDER-left: 1 solid #254A6F; border-right: 1 solid #254A6F; border-bottom: 1 solid #254A6F; LEFT: 0px; BOTTOM: 0px; POSITION: absolute; TOP: 0px;
hspace: 0px" frameborder="0" scrolling="Auto"> >>>

Try validating your code, stick to lower case in styles, it's easier to read. Border-right: 1 solid #254a6f;

1 what? 1px, 1em, 1pt etc? You have to put in the units with CSS, it's not optional.

Go to the w3c css validator and validate your code, if this was wrong I'm sure a bunch of other stuff was wrong. Once you get your HTML and CSS to validate I think you'll find the display 'errors' go away.

cmatcme

5+ Year Member



 
Msg#: 231 posted 7:49 pm on Mar 11, 2005 (gmt 0)

In order for a proper validation you'll need a doctype [w3.org]!

<added> Meta tags should be inside the head tags </added>

RangerChic

5+ Year Member



 
Msg#: 231 posted 4:42 am on Mar 12, 2005 (gmt 0)

Thanks! I'll give your suggestions a go.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Browsers / Firefox Browser Usage and Support
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved