homepage Welcome to WebmasterWorld Guest from 54.242.126.9
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Browsers / Opera Browser Usage and Support
Forum Library, Charter, Moderator: open

Opera Browser Usage and Support Forum

    
Photo Slideshow not working in Opera
jjasper

5+ Year Member



 
Msg#: 450 posted 2:17 pm on Mar 16, 2005 (gmt 0)

I'm working on a photo slideshow that seems to be working fine in IE, FireFox, Netscape and Safari (both Mac & PC of IE and Netscape). Opera is the only hold out.

JavaScript runs the slideshow and what should be happening is that you click the speed buttons and it cycles through all images in a particular album. In opera, it goes to the next image and stops. You must press the stop button and then the forward button to proceed only one image.

Has anyone seen this problem in other cases? it's as if the delay and time-out parameters are locking up the slideshow, but there are no JavaScript errors showing up in Opera's JavaScript console.

Thanks for any help.

 

tedster

WebmasterWorld Senior Member tedster us a WebmasterWorld Top Contributor of All Time 10+ Year Member



 
Msg#: 450 posted 4:36 am on Mar 17, 2005 (gmt 0)

Opera's javascript support is improving with each version but there are still gaps. I would be very surprised if standard methods like setTimeout are not working, but I'd make a first guess that there's something extra in the "set your speed" section of this script that is causing the problem.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Browsers / Opera Browser Usage and Support
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved