homepage Welcome to WebmasterWorld Guest from 54.237.38.30
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Pubcon Platinum Sponsor 2014
Home / Forums Index / Hardware and OS Related Technologies / Webmaster Hardware
Forum Library, Charter, Moderator: open

Webmaster Hardware Forum

    
USB printer problems. Urgent.
Epson c64 stylus
phidentity

10+ Year Member



 
Msg#: 290 posted 12:27 pm on Aug 24, 2005 (gmt 0)

Hi

Bought this printer today. Plugged in, and it detects a USB printer is connected. Search auto for drivers, it finds driver CD and correct .inf file...but says 'hardware couldnt be installed'.

I delete the printer and then try using the automated software on the CD, and that works up until it tries to detect the printer, at that point it fails and installs the printer as LTP1...it's a usb printer.

I have tried everything, either windows detects it and then cant install it, or I install the driver software, and it can't find the printer.

What can I do?

Jon

 

oddsod

WebmasterWorld Senior Member 5+ Year Member



 
Msg#: 290 posted 12:38 pm on Aug 24, 2005 (gmt 0)

Don't the manuals usually advise you to install all the drivers before plugging the printer in? Have you tried that? Also, does the printer print the "test page" OK without being plugged into the PC?

PCInk

WebmasterWorld Senior Member 10+ Year Member



 
Msg#: 290 posted 12:59 pm on Aug 24, 2005 (gmt 0)

Or you could try installing as LPT1, then going to Printers And Faxes in Control Panel, going to properties then ports and change the port to USB. May not work, but worth a try for a few clicks.

phidentity

10+ Year Member



 
Msg#: 290 posted 1:08 pm on Aug 24, 2005 (gmt 0)

This one advised me to plug it in then put drivers in. I tried the other way round also but it didnt work.

I try also allowing it to be LPT1 and then changing port but I recieve an error message saying the port cannot be created. :(

Will try and print test page without being plugged in.

Jon

Marcia

WebmasterWorld Senior Member marcia us a WebmasterWorld Top Contributor of All Time 10+ Year Member



 
Msg#: 290 posted 1:16 pm on Aug 24, 2005 (gmt 0)

Are you sure it's compatible with your operating system? And is there another printer still installed that could be causing a conflict?

phidentity

10+ Year Member



 
Msg#: 290 posted 1:19 pm on Aug 24, 2005 (gmt 0)

It has XP drivers which i've downloaded.

I have no other USB printers. I've uninstalled my other printer (LPT1), still no success. :(

Jon

SEOMike

WebmasterWorld Senior Member 10+ Year Member



 
Msg#: 290 posted 6:24 pm on Aug 24, 2005 (gmt 0)

Do other USB devices work for you? Have you tried another USB port? Are you using a hub between the printer and the computer? Do you have another computer where you could test the printer?

longen

WebmasterWorld Senior Member 10+ Year Member



 
Msg#: 290 posted 7:21 pm on Aug 25, 2005 (gmt 0)

This one advised me to plug it in then put drivers in

I have the C46, not the C64, and it says:

1) Turn OFF the printer
2) Connect Printer to PC with USB cable
3) Install printer software

phidentity

10+ Year Member



 
Msg#: 290 posted 9:25 am on Aug 26, 2005 (gmt 0)

I tried my 2 USB ports. (I have more but the are not plugged into the mobo, and I have no idea how to...).

Cannot get it working. Works at my brothers.

I really need to format my PC... it's been too long and it's filled with niggly problems. Oh damn.

Jon

collymellon

5+ Year Member



 
Msg#: 290 posted 8:47 pm on Aug 30, 2005 (gmt 0)

Have you solved it yet?

go into system properties and do device manager. Expand serial bus conrollers and update driver on all.

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Hardware and OS Related Technologies / Webmaster Hardware
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved