homepage Welcome to WebmasterWorld Guest from 54.161.246.212
register, free tools, login, search, pro membership, help, library, announcements, recent posts, open posts,
Become a Pro Member

Home / Forums Index / Code, Content, and Presentation / Flash and Shockwave
Forum Library, Charter, Moderator: open

Flash and Shockwave Forum

    
linking with flash buttons
my flash buttons only work once in templates?
smokeyb

10+ Year Member



 
Msg#: 88 posted 8:02 pm on Nov 25, 2003 (gmt 0)

I have just started using templates for my pages but a problem has arisen. I use little animated flash buttons in my nav bar, which seem to work fine and link you to the page. But when you hit the same button in the page you have opened (so your pressing a button that links to the page you are viewing) it comes up with the "cannot find server, page cannot be displayed" old carrot. Is there an inherent problem using a combination of .swf buttons and templates? Or can anyone help with this?
Thanks

 

tedster

WebmasterWorld Senior Member tedster us a WebmasterWorld Top Contributor of All Time 10+ Year Member



 
Msg#: 88 posted 4:01 am on Nov 26, 2003 (gmt 0)

This sits odd with me. If the browser reports it cannot find the server, then it's being asked to find an incorrect URL.

Templates should not be the issue, just in and of themselves (I assume you mean DreamWeaver templates?) But something is obviously off.

If you view the source in the page where the error occurs, do you see an incorrect URL?

smokeyb

10+ Year Member



 
Msg#: 88 posted 9:40 pm on Nov 26, 2003 (gmt 0)

Definitely odd Tedster? especially if YOU don't know why. I have b*ggered about with this for too long and it still won't work. When I have some funky idea, I usually quickly set something up to see if it works, before I press on with it. But sometimes I mess up the links as the set-up isn't yet structured. But I have taken my time to thoroughly check this idea out a dozen times, but it just won't work. As I have said, it will go to a page but won't open the same page you are in, and it works fine if I just use a gif as a button? Can I use javascript to call the page instead of the <a href> tag? maybe that'll work? if not I'll just use gifs and be damned!

smokeyb

10+ Year Member



 
Msg#: 88 posted 10:35 pm on Nov 26, 2003 (gmt 0)

It's ok, I've figured it out. For the record, this was my problem: I noticed that in the template my links went up a level out of the templates folder, but the link modified on the page the template is applied to. I saw a link that was ../blah.htm in the template and just blah.htm in the uneditable code on the page using the template. All I have to do is navigate from page to page with my flash buttons ignoring the template, and it should work. Obviously I don't know much about templates eh?
Thanks anyway

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / Flash and Shockwave
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Home ¦ Free Tools ¦ Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About ¦ Library ¦ Newsletter
WebmasterWorld is a Developer Shed Community owned by Jim Boykin.
© Webmaster World 1996-2014 all rights reserved