homepage Welcome to WebmasterWorld Guest from 107.21.163.227
register, free tools, login, search, subscribe, help, library, announcements, recent posts, open posts,
Pubcon Website
Home / Forums Index / Code, Content, and Presentation / Flash and Shockwave
Forum Library, Charter, Moderator: open

Flash and Shockwave Forum

    
Advertisement not clicking through correctly
OPens in both new window AND iFrame ...
lZakl




msg:1565189
 5:51 pm on Jun 6, 2006 (gmt 0)

Hello,

I am wondering if anyone has had this problem in the past. We are using a 3rd party vendor for our ad tracking - impressions, clickthroughs etc... This 3rd party loads the ads to the pages using iFrames. Pretty much we create a hole, they fill it. So here's the problem:

When I build and load a Flash ad onto the page, the clickthrough does not work correctly. IT will open the clickthrough website in a new window which is what is expected, but it also loads the clickthrough website into the iframe. You can imagine how dorky this looks ... especially to the advertiser. Here is what I place as far as my ActionScripting:

on (release) {
getURL("http://example.com",'target="_blank"');
}

on (release) {
if (clickTAG.substr(0,5) == "http:") {
getURL(clickTAG);
}
}

I appreciate any info/input you may have on this matter!

-- Zak

 

oxbaker




msg:1565190
 4:44 pm on Jun 7, 2006 (gmt 0)

replace

getUrl(clickTAG) with
getUrl(clickTAG, "_blank");

should do it.

mcm

Global Options:
 top home search open messages active posts  
 

Home / Forums Index / Code, Content, and Presentation / Flash and Shockwave
rss feed

All trademarks and copyrights held by respective owners. Member comments are owned by the poster.
Terms of Service ¦ Privacy Policy ¦ Report Problem ¦ About
© Webmaster World 1996-2014 all rights reserved